Bug 1183027 - Pie chart colors are wrong
Summary: Pie chart colors are wrong
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: 6.0 (Juno)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Ana Krivokapic
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On: 1231945
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-16 13:49 UTC by Ana Krivokapic
Modified: 2015-08-05 13:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:50:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ana Krivokapic 2015-01-16 13:49:55 UTC
Description of problem:
Pie chart colors on the node overview page should be different shades of blue only. In the case of a RHOS installation, other colors appear besides blue: orange, green, etc. This is probably due to RCUE CSS, since upstream the colors are correct.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open the node overview page

Actual results:
Pie chart colors include non-blue colors (green, orange).


Expected results:
Only shades of blue should be present in pie chart colors.


Additional info:

Comment 3 Ana Krivokapic 2015-02-16 08:47:57 UTC
Upstream patches on review:
https://review.openstack.org/#/c/154956/
https://review.openstack.org/#/c/154957/

Comment 4 Ana Krivokapic 2015-02-16 08:56:08 UTC
These are actually fixed in upstream Kilo horizon:
https://review.openstack.org/#/c/125330/
https://review.openstack.org/#/c/130773/

Comment 8 Udi 2015-06-29 17:00:43 UTC
Can't test until bug https://bugzilla.redhat.com/show_bug.cgi?id=1231945 is fixed. The pies are all blue now, always on 100%.

Comment 9 Mike Burns 2015-06-29 17:50:58 UTC
Can't test doesn't mean failed qa.  If testing is blocked, then it can stay in ON_QA for now until the other is fixed with the Depends On field set.

Comment 10 Udi 2015-07-05 12:15:04 UTC
Verified: 
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-8.el7ost.noarch

Comment 12 errata-xmlrpc 2015-08-05 13:50:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.