Bug 1231945 - Tuskar-UI pie charts don't display states correctly
Summary: Tuskar-UI pie charts don't display states correctly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tuskar-ui
Version: Director
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ga
: Director
Assignee: Ana Krivokapic
QA Contact: Ola Pavlenko
URL:
Whiteboard:
: 1234331 (view as bug list)
Depends On:
Blocks: 1183027
TreeView+ depends on / blocked
 
Reported: 2015-06-15 16:34 UTC by Ana Krivokapic
Modified: 2015-08-05 13:53 UTC (History)
6 users (show)

Fixed In Version: openstack-tuskar-ui-0.3.0-4.el7ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-05 13:53:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
node states (34.92 KB, image/png)
2015-06-15 16:34 UTC, Ana Krivokapic
no flags Details
Nodes overview page showing all pie charts on 100% (139.09 KB, image/png)
2015-06-29 18:19 UTC, Udi
no flags Details
Charts with correct percentages (30.68 KB, image/png)
2015-06-30 13:11 UTC, Ana Krivokapic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:1549 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform director Release 2015-08-05 17:49:10 UTC

Description Ana Krivokapic 2015-06-15 16:34:31 UTC
Created attachment 1039133 [details]
node states

Pie charts describing node states (on the nodes overview page) don't detect the states properly. They always display all states as 0%. This is probably due to ironic client changes that introduced new states/changed association of old states.

Comment 4 Ana Krivokapic 2015-06-18 13:57:55 UTC
https://review.openstack.org/#/c/193052/

Comment 5 Ana Krivokapic 2015-06-22 13:51:19 UTC
*** Bug 1234331 has been marked as a duplicate of this bug. ***

Comment 7 Udi 2015-06-29 16:58:28 UTC
Now the states show all 100%. Bug is re-opened.

Comment 8 Ana Krivokapic 2015-06-29 17:25:29 UTC
Could you attach a screenshot please.

Comment 9 Udi 2015-06-29 18:19:06 UTC
Created attachment 1044435 [details]
Nodes overview page showing all pie charts on 100%

Screenshot attached. I have 2 free nodes but the pie chart shows that 100% are provisioned.

Comment 10 Ana Krivokapic 2015-06-30 13:11:08 UTC
Created attachment 1044680 [details]
Charts with correct percentages

Comment 11 Ana Krivokapic 2015-06-30 13:14:03 UTC
Couldn't reproduce this on the latest puddle (with openstack-tuskar-ui-0.3.0-6.el7ost.noarch). The charts are correctly showing 2 nodes as deployed and 1 as free. Please see the attachment. Could you please re-test with the latest puddle (2015-06-29.1​).

Comment 12 Udi 2015-07-05 12:14:34 UTC
openstack-tuskar-ui-extras-0.0.4-1.el7ost.noarch
openstack-tuskar-ui-0.3.0-8.el7ost.noarch

Comment 14 errata-xmlrpc 2015-08-05 13:53:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2015:1549


Note You need to log in before you can comment on or make changes to this bug.