Bug 1183318 - [HC] - Do not allow adding GlusterFS storage domain, if hosts of the selected dc, do not report they have the GlusterFS packages.
Summary: [HC] - Do not allow adding GlusterFS storage domain, if hosts of the selected...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: m1
: 3.6.0
Assignee: Ala Hino
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks: 1160653 Generic_Hyper_Converged_Host
TreeView+ depends on / blocked
 
Reported: 2015-01-18 15:18 UTC by Yaniv Lavi
Modified: 2016-03-10 06:11 UTC (History)
22 users (show)

Fixed In Version: 3.6.0-11
Doc Type: Bug Fix
Doc Text:
Cause: Missing glusterfs-cli packages on the host. Consequence: Adding glusterfs storage domains fails with unknown filesystem 'glusterfs' error. Fix: Check to verify whether glusterfs-cli package installed. This check is applicable only for clusters version >= 3.6. Result: When creating glusterfs storage domains, we check whether glusterfs-cli installed. If not, operation fails and a message is displayed to the admin explaining that glusterfs packages are not installed on the host. Same check is performed when adding hosts: if cluster version is >= 3.6 and there is an active gluster storage domain, if the glusterfs-cli package is not installed on the host, the host cannot be added and a message is displayed to the admin. Same check is performed when activating hosts: if cluster is >= 3.6 and there is an active gluster storage domain, if the glusterfs-cli package is not installed on the host, the host becomes non-op.
Clone Of: 1160653
Environment:
Last Closed: 2015-11-04 11:33:20 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1289585 0 unspecified CLOSED [Upgrade][Gluster] Host moves to Non operational after vdsm upgrade due to a missing gluster-cli package 2021-02-22 00:41:40 UTC
oVirt gerrit 44334 0 master MERGED gluster: Add validation when connecting gluster SD Never
oVirt gerrit 44581 0 master MERGED gluster: Report glusterfs-cli package details Never
oVirt gerrit 44611 0 master MERGED core: retrieve and store glusterfs-cli package version Never
oVirt gerrit 44612 0 master MERGED core: check glusterfs-cli package availability on vds activation Never
oVirt gerrit 45228 0 ovirt-3.6 MERGED gluster: Report glusterfs-cli package details Never
oVirt gerrit 45485 0 ovirt-engine-3.6 MERGED core: retrieve and store glusterfs-cli package version Never
oVirt gerrit 45486 0 ovirt-engine-3.6 MERGED core:refactor: Refactor code to be reused in future patch Never
oVirt gerrit 45487 0 ovirt-engine-3.6 MERGED gluster: Add validation when connecting gluster SD Never
oVirt gerrit 45488 0 ovirt-engine-3.6 MERGED core:refactor: Split logic to new method Never
oVirt gerrit 45489 0 ovirt-engine-3.6 MERGED core:refactor: Add IStorageHelper.prepareConnectHostToStoragePoolServers Never
oVirt gerrit 45490 0 ovirt-engine-3.6 MERGED core:refactor: Add IStorageHelper.prepareDisconnectHostFromStoragePoolServers Never
oVirt gerrit 45491 0 ovirt-engine-3.6 MERGED core:refactor: Add IStorageHelper.disconnectHostFromStoragePoolServersCommandCompleted Never
oVirt gerrit 45492 0 ovirt-engine-3.6 MERGED core:refactor: Move cinder logic to CINDERStorageHelper Never
oVirt gerrit 45493 0 ovirt-engine-3.6 MERGED core: check glusterfs-cli package availability on vds activation Never

Internal Links: 1289585

Comment 1 Allon Mureinik 2015-03-26 14:21:40 UTC
Vijay, I initially thought VDSM could inspect /proc/filesystems in order to deduce if it has glusterfs installed, but it doesn't seem to be there (using upstream glusterfs 3.6.2-1).

Is this the intended behavior, or is this just the wrong way to check?

Comment 2 Vijay Bellur 2015-04-27 12:26:10 UTC
(In reply to Allon Mureinik from comment #1)
> Vijay, I initially thought VDSM could inspect /proc/filesystems in order to
> deduce if it has glusterfs installed, but it doesn't seem to be there (using
> upstream glusterfs 3.6.2-1).
> 
> Is this the intended behavior, or is this just the wrong way to check?

This indeed is intended behavior as gluster is in userspace. Maybe a good way to check would be through rpm -qa | grep glusterfs-fuse/glusterfs-api depending on the storage domain integration in use.

Comment 3 Yaniv Lavi 2015-04-27 13:06:54 UTC
(In reply to Vijay Bellur from comment #2)
> (In reply to Allon Mureinik from comment #1)
> > Vijay, I initially thought VDSM could inspect /proc/filesystems in order to
> > deduce if it has glusterfs installed, but it doesn't seem to be there (using
> > upstream glusterfs 3.6.2-1).
> > 
> > Is this the intended behavior, or is this just the wrong way to check?
> 
> This indeed is intended behavior as gluster is in userspace. Maybe a good
> way to check would be through rpm -qa | grep glusterfs-fuse/glusterfs-api
> depending on the storage domain integration in use.

What about distros that don't have a concept of RPMs, also dev environments.
Is there a way to do it without rpms specific checks?

Comment 4 Nir Soffer 2015-04-27 13:43:04 UTC
We can check if the gluster command line is available. If we can run gluster and get its version, we can assume that gluster is installed.

Or simpler, require glusterfs client tools on a host.

Comment 6 Yaniv Lavi 2015-06-15 11:42:41 UTC
Is the 3.7 client gluster packages planned to be in the regular RHEL 7 channels?

Comment 7 Sahina Bose 2015-07-22 16:21:19 UTC
glusterfs-cli package is available in RHEL optional channel

Comment 8 Nir Soffer 2015-07-22 21:56:35 UTC
(In reply to Sahina Bose from comment #7)
> glusterfs-cli package is available in RHEL optional channel

Sahina: But it is not available on ppc - right?

Yaniv: Vdsm already has a cross-platform way to report existing package,
using either rpm or apt python bindings.

Comment 9 Sahina Bose 2015-07-23 06:08:55 UTC
(In reply to Nir Soffer from comment #8)
> (In reply to Sahina Bose from comment #7)
> > glusterfs-cli package is available in RHEL optional channel
> 
> Sahina: But it is not available on ppc - right?

Right  not available on ppc

> 
> Yaniv: Vdsm already has a cross-platform way to report existing package,
> using either rpm or apt python bindings.

Comment 10 Allon Mureinik 2015-09-03 13:39:54 UTC
Ala, please add the required doctext to this bug.

Comment 11 Aharon Canan 2015-09-07 09:51:49 UTC
Testing using 3.6.0-11

Option is not greyed out like Yaniv.
Instead I got below error message (which can work)

"Error while executing action: Cannot add Storage Connection. Host camel-vdsc.qa.lab.tlv.redhat.com cannot connect to Glusterfs. Verify that glusterfs-cli package is installed on the host."

Yaniv - are we good with it or do you want it greyedout only?

Comment 12 Aharon Canan 2015-09-08 06:54:07 UTC
Please be aware to https://bugzilla.redhat.com/show_bug.cgi?id=1260754

I think it is related to this fix...

Comment 13 Aharon Canan 2015-09-08 12:04:24 UTC
(In reply to Aharon Canan from comment #11)
> Testing using 3.6.0-11
> 
> Option is not greyed out like Yaniv.
> Instead I got below error message (which can work)
> 
> "Error while executing action: Cannot add Storage Connection. Host
> camel-vdsc.qa.lab.tlv.redhat.com cannot connect to Glusterfs. Verify that
> glusterfs-cli package is installed on the host."
> 
> Yaniv - are we good with it or do you want it greyedout only?

Yaniv - 
If we want it greyed out please reopen.

Marking as verified as we have informative message.

Comment 14 Yaniv Lavi 2015-09-08 12:51:40 UTC
Is it the same as in the CEPH package testing?

Comment 15 Aharon Canan 2015-09-08 12:57:17 UTC
(In reply to Yaniv Dary from comment #14)
> Is it the same as in the CEPH package testing?

Do not know, didn't test ceph pkg yet

Comment 16 Ala Hino 2015-09-08 13:03:43 UTC
I understand from derez that behavior is the same

Comment 17 Yaniv Lavi 2015-09-08 13:17:30 UTC
(In reply to Ala Hino from comment #16)
> I understand from derez that behavior is the same

This solution is acceptable by me, we will see if any customers will complain about this and we can change this if needed.

Comment 18 Aharon Canan 2015-09-08 13:20:47 UTC
(In reply to Yaniv Dary from comment #17)
> (In reply to Ala Hino from comment #16)
> > I understand from derez that behavior is the same
> 
> This solution is acceptable by me, we will see if any customers will
> complain about this and we can change this if needed.

So why not doing it right from the beginning instead of waiting for costumers to complain and then do it again??

Comment 19 Yaniv Lavi 2015-09-08 13:22:48 UTC
(In reply to Aharon Canan from comment #18)
> (In reply to Yaniv Dary from comment #17)
> > (In reply to Ala Hino from comment #16)
> > > I understand from derez that behavior is the same
> > 
> > This solution is acceptable by me, we will see if any customers will
> > complain about this and we can change this if needed.
> 
> So why not doing it right from the beginning instead of waiting for
> costumers to complain and then do it again??

Doing it right is not a science, I think should cover the requirement and I don't expect customer issues on this. If there will be we will consider changing the flow.

Comment 20 Ala Hino 2015-09-08 13:30:02 UTC
(In reply to Yaniv Dary from comment #19)
> (In reply to Aharon Canan from comment #18)
> > (In reply to Yaniv Dary from comment #17)
> > > (In reply to Ala Hino from comment #16)
> > > > I understand from derez that behavior is the same
> > > 
> > > This solution is acceptable by me, we will see if any customers will
> > > complain about this and we can change this if needed.
> > 
> > So why not doing it right from the beginning instead of waiting for
> > costumers to complain and then do it again??
> 
> Doing it right is not a science, I think should cover the requirement and I
> don't expect customer issues on this. If there will be we will consider
> changing the flow.

Note that grade-out functionalities is not too common in the GUI.
In this specfic case, when creating a new storage domain, a new popup is opened and admin checks storage type from a drop-down. Do we expect drop-down content to dynamically change based on one condition or another? This cold be a killer once done every time admin opens the drop-down. It is not simply grade-out the "New Domain" button if glusterfs packages are not installed.

Comment 21 Sandro Bonazzola 2015-11-04 11:33:20 UTC
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.


Note You need to log in before you can comment on or make changes to this bug.