Bug 118394 - W8 C6 exercise grading too restrictive...
W8 C6 exercise grading too restrictive...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Academy
Classification: Retired
Component: RHA030 Curriculum (Show other bugs)
2.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bowe Strickland
Bowe Strickland
:
: 122702 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 06:54 EST by Bowe Strickland
Modified: 2007-04-18 13:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 12:30:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2004-03-16 06:54:42 EST
Apparently, the grading is only accepting the results only if
thiscommand is run:

diff -ur
/usr/share/gedit-2/taglist/Latex.tags/home/ql004/gedit-2/taglist/Latex.tagsnot


this, which is more common (note the order of switches):diff -ru
/usr/share/gedit-2/taglist/Latex.tags/home/ql004/gedit-2/taglist/Latex.tags
Comment 1 Garry 2004-05-10 02:05:32 EDT
*** Bug 122702 has been marked as a duplicate of this bug. ***
Comment 2 Brad Smith 2004-06-14 22:30:05 EDT
The reason this fails is because diff -r always includes the complete
command-line used to generate each comparison. Thus the outputs of
diff -ur and diff -ru will always be different though never in a
significant way. 

Possible solutions:

 * Alter the back-end to diff the result of `grep -v ^diff filename`
instead of filename (this should not result in any false positives
since anything from the actual text of the documents should be
preceeded with '+++' or '---'. 

 * Alter the exercise to do a diff -u on two individual files instead
of on a directory tree. 

 * Alter the exercise to do a diff -r (without other arguments) on the
directory trees.

Bowe and I will work on this and update the courseware as nescessary.
Comment 3 Brad Smith 2004-06-17 19:00:37 EDT
Fix is in CVS.

The simplest solution was chosen: The exercise now has the student do
a recursive diff instead of a unified, recursive diff.
Comment 4 Bowe Strickland 2005-01-05 11:33:29 EST
updated script to match text

Note You need to log in before you can comment on or make changes to this bug.