Bug 118409 - Croatian key layout
Croatian key layout
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: xkb-croatian (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 09:48 EST by Ivan Perzan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 07:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Perzan 2004-03-16 09:48:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
In the Croatian keyboard layout the is no "_" key at it's place is
"?". So we have "?" un the upper row next to 0 where it should be and
beside right shift where should be "_". The rest of keys are ok. The
Slovenian key layout is OK so I'm using it so I can type (Croatian
letters)

Version-Release number of selected component (if applicable):
redhat-config-keyboard-1.1.5-2

How reproducible:
Always

Steps to Reproduce:
1.Main menu
2.System settings
3.keyboard
4. Croatian
    

Additional info:
Comment 1 Brent Fox 2004-03-17 13:23:19 EST
I have verified this problem but the actual xkb keymap comes from the
XFree86 package, not redhat-config-keyboard.  Changing components to
XFree86.

I google'd for a Croation keyboard layout and found:
http://www.hermessoft.com/newproject/keyboards/croatian.html

It looks like the bug is not with the button just to the right of the
0 key.  It is with the button just to the left of the right Shift key.
 It should be displaying "-" when pressed and "_" when Shift is held
down.  Instead, it is displaying "/" and "?" just like it does in English.

It appears to me that the kbd keymap is doing the right thing and the
xkb keymap should behave the same way as kbd.
Comment 2 Mike A. Harris 2004-07-05 19:10:20 EDT
I'm not quite sure what the correct behaviour should be for this.
I'm inclined to agree with Brent however, as that seems the
most sensible to me.  I'm going to close this as "NOTABUG", however
if you still think there is a bug present for the croatian
keyboard, I recommend filing a bug report in the upstream bugzilla at
freedesktop.org, against the xkbdesc component.  The Xkb maintainer
is more authoritative in such matters and responds rather quickly
to such issues.

If you file a report upstream, and paste the URL here, we'll track
the issue for you, and consider backporting any fixes that become
available.

Thanks for your report.
Comment 3 Mike A. Harris 2004-07-05 23:51:12 EDT
*** Bug 126243 has been marked as a duplicate of this bug. ***
Comment 4 Hrvoje Dagelic 2004-07-27 06:30:40 EDT
*Ako zelite ovo rjesiti izvedite ovu naredbu:

cp /lib/kbd/keymaps/i386/qwertz/slovene.map.gz
/lib/kbd/keymaps/i386/qwertz/croat.map.gz 

______________________ :)
*If you want to fix this execute this command...


I suggest that you (fedora developers) also do this. Croatian and
Slovene keymaps are identical.
Comment 5 Mike A. Harris 2004-09-01 07:12:23 EDT
This bug was flagged "UPSTREAM" for tracking in upstream bugzilla,
however there's no upstream bug URL present for us to
investigate/track the status of.

I'm assuming the problem no longer exists in Fedora Core development
builds (rawhide), and closing the report as "RAWHIDE".  If the
problem exists in rawhide xorg-x11 still, please file a bug report
in the X.Org upstream bugzilla at http://bugs.freedesktop.org and
paste the URL here if you'd like us to track it.

Thanks in advance.
Comment 6 Ivo P. 2004-10-22 05:27:30 EDT
just add the following line 

key <AB10> { [ minus, underscore, dead_belowdot, dead_abovedot ] };

to the /etc/X11/xkb/symbols/pc/hr   file

Note You need to log in before you can comment on or make changes to this bug.