Bug 118434 - Dependancies on XFree86-xfs should not be present
Dependancies on XFree86-xfs should not be present
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gtkglarea (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
: 118473 (view as bug list)
Depends On:
Blocks: xorgdeps
  Show dependency treegraph
 
Reported: 2004-03-16 13:28 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.2-19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 00:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2004-03-16 13:28:17 EST
There are hard coded dependancies on XFree86 package, which
needs to be fixed before xorg-x11 can be enabled in the development
tree.

The following is found in the spec file:
    Requires: XFree86 >= 4.0, gtk+ >= 1:1.2.6
    Buildrequires: XFree86 >= 4.0, XFree86-devel >= 4.0, gtk+-devel >=
1:1.2.6, Mesa-devel >= 3.4.2


Looking at the changelog, these were added a long time ago to solve
issues that are no longer solved by this method.  The above lines
should be changed to read:

    Requires: gtk+ >= 1:1.2.6
    Buildrequires: XFree86-devel >= 4.0, gtk+-devel >= 1:1.2.6

The XFree86-devel is an issue also, but I'm going to include
a Provides: XFree86-devel = 4.4.0 in xorg-x11 packaging for the
time being, and solve the XFree86-devel related problems in the
future with new bug reports instead, as that problem is much
harder to solve right now in a quick and clean way.

In the future, libGL development bits will be provided by

BuildRequires: libGL-devel

That can't go in just yet though.
Comment 1 Bill Nottingham 2004-03-16 17:47:05 EST
Then again, if we don't ship xtraceroute, we probably don't need to
ship gtkglarea either...
Comment 2 Bill Nottingham 2004-03-16 17:50:27 EST
*** Bug 118473 has been marked as a duplicate of this bug. ***
Comment 3 Mike A. Harris 2004-03-17 00:46:25 EST
Fixed in gtkglarea-1.2.2-19 in rawhide

Note You need to log in before you can comment on or make changes to this bug.