Bug 118458 - redhat-logviewer sh: line 1: /usr/sbin/tux2w3c: No such file or directory
redhat-logviewer sh: line 1: /usr/sbin/tux2w3c: No such file or directory
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-logviewer (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tammy Fox
:
: 119627 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-16 15:28 EST by Clive Long
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 17:16:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clive Long 2004-03-16 15:28:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Just updated Fedora Core 1 to XFree86 4.4 using XFree86 binaries from
XFree site - to try and solve X crash.

The active kernel is 2.4.22-1.2174.nptl 
When I run redhat-logviewer with the 4.4 version of X and kernel 2.4
end up with following error messages. The problem did NOT occur with
XFree 4.3 downloaded from Fedora mirror

********************************
Log view Start error messages follow
********************************
[clive_long@localhost sbin]$ redhat-logviewer
sh: line 1: /usr/sbin/tux2w3c: No such file or directory
Traceback (most recent call last):
  File "/usr/share/redhat-logviewer/redhat-logviewer.py", line 80, in ?
    LogViewerGui.LogViewerGui(width,height, allowConfigChanges,
configFile,initialView)
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 162, in
__init__
    self.initial_read_of_file()
  File "/usr/share/redhat-logviewer/LogViewerGui.py", line 343, in
initial_read_of_file
    logClassInstance = LogFileClass.LogFileClass(key)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 74, in __init__
    self.read_log(self.prefName)
  File "/usr/share/redhat-logviewer/LogFileClass.py", line 140, in
read_log
    self.buffer.insert_into_buffer_at_offset(iter, line)
  File "/usr/share/redhat-logviewer/LogBuffer.py", line 71, in
insert_into_buffer_at_offset
    langEnVar = os.environ["LANG"]
  File "/usr/lib/python2.2/UserDict.py", line 14, in __getitem__
    def __getitem__(self, key): return self.data[key]
KeyError: LANG


Version-Release number of selected component (if applicable):
redhat-logviewer-0.9.3-6

How reproducible:
Always

Steps to Reproduce:
1. run command redhat-logviewer

Actual Results:  See error messages above

Expected Results:  Log viewer starts correctly under Xfree86 4.4 as
under Xfree86 4.3

Additional info:
Comment 1 Tammy Fox 2004-03-16 15:39:32 EST
/usr/sbin/tux2w3c only gets executed if redhat-logviewer finds a Red
Hat Content Accelerator log file (/var/log/tux) to convert it to text.
Do you have a /var/log/tux file? Do you have the tux package installed?
Comment 2 Clive Long 2004-03-16 16:56:17 EST
1. Do you have a /var/log/tux file?
NO

2. Do you have the tux package installed?
[clive_long@localhost clive_long]$ rpm -q tux
package tux is not installed
Comment 3 Eric Lawson 2004-04-01 14:04:08 EST
I have the same bug using Redhat EL WS 3, and am also lacking a
/var/log/tux file, with no tux package installed (rpm -qa | grep tux)
returns nothing.
Comment 4 Tammy Fox 2004-04-15 11:55:05 EDT
*** Bug 119627 has been marked as a duplicate of this bug. ***
Comment 5 Tammy Fox 2004-04-15 15:28:10 EDT
I wan't able to reproduce the 
redhat-logviewer sh: line 1: /usr/sbin/tux2w3c: No such file or directory
error message on an FC1 system, but I am able to on an FC2 test2 machine.

I am looking at it now.
Comment 6 Tammy Fox 2004-04-15 17:16:24 EDT
Fixed in version 0.9.7-1.

Note You need to log in before you can comment on or make changes to this bug.