Bug 118527 - 3d graphics causes X to hang immediately (i865)
3d graphics causes X to hang immediately (i865)
Status: CLOSED DUPLICATE of bug 117713
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 08:56 EST by Jens Petersen
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2004-03-17 08:56:21 EST
Description of problem:
Running any kind of 3d graphics causes to X to freeze up
completely and hang this i865 box. 

Version-Release number of selected component (if applicable):
XFree86-4.3.0-63
xorg-x11-0.0.6.6-0.0.2004_03_11.4
kernel-2.6.3-2.1.253.2.1

How reproducible:
every time

Steps to Reproduce:
1. Run Bubbles3D screensaver.
2. or tuxracer
3. or wait for some 3d screensaver to start...
  
Actual results:
Console hangs hard - though the machine is still accessible
via ssh for example.

Expected results:
3d graphics running normally.

Additional info:
This is a regression compared to FC1.
Comment 1 Jens Petersen 2004-03-17 09:25:08 EST
Mar 17 23:17:49 box12 kernel: Unable to handle kernel paging request
at virtual
address f520e000
Mar 17 23:17:49 box12 kernel:  printing eip:
Mar 17 23:17:49 box12 kernel: 1a27869c
Mar 17 23:17:49 box12 kernel: *pde = 00000000
Mar 17 23:17:49 box12 kernel: Oops: 0002 [#1]
Mar 17 23:17:49 box12 kernel: CPU:    0
Mar 17 23:17:49 box12 kernel: EIP:    0060:[<1a27869c>]    Not tainted
Mar 17 23:17:49 box12 kernel: EFLAGS: 00010202   (2.6.3-2.1.253.2.1)
Mar 17 23:17:49 box12 kernel: EIP is at
i830_dma_dispatch_vertex+0x1c1/0x467 [i830]
Mar 17 23:17:49 box12 kernel: eax: 7f0003ef   ebx: 00000004   ecx:
f520e000   edx: 1a217898
Mar 17 23:17:49 box12 kernel: esi: 000003f1   edi: 14fca7d8   ebp:
00000fc4   esp: 044aaf04
Mar 17 23:17:49 box12 kernel: ds: 007b   es: 007b   ss: 0068
Mar 17 23:17:49 box12 kernel: Process gflux (pid: 2031,
threadinfo=044aa000 task=04559980)
Mar 17 23:17:49 box12 kernel: Stack: 0000000c 0216527c 000ef2f8
00000000 ef2f8000 00000001 1a2181d0 1a217898
Mar 17 23:17:49 box12 kernel:        14588aa0 00000001 0ee88000
14ff119c 14ff119c 14fca7d8 12a94000 1a217898
Mar 17 23:17:49 box12 kernel:        1a278c3b 00000fc4 0eeba000
00000000 00000fc4 00000001 00000001 14ff119c
Mar 17 23:17:49 box12 kernel: Call Trace:
Mar 17 23:17:49 box12 kernel:  [<0216527c>] rw_vm+0x310/0x3aa
Mar 17 23:17:49 box12 kernel:  [<1a278c3b>] i830_dma_vertex+0xbb/0xdf
[i830]
Mar 17 23:17:49 box12 kernel:  [<1a273dff>] i830_ioctl+0xe3/0xef [i830]
Mar 17 23:17:49 box12 kernel:  [<1a278b80>] i830_dma_vertex+0x0/0xdf
[i830]
Mar 17 23:17:49 box12 kernel:  [<0217c1cb>] sys_ioctl+0x2a0/0x341
Mar 17 23:17:49 box12 kernel:
Mar 17 23:17:49 box12 kernel: Code: 89 01 83 bf a8 00 00 00 00 74 0a
c7 04 b1 00 00 00 05 83 c5
Comment 2 Sahil Verma 2004-03-17 13:48:00 EST
Dupe of 117642 and 117713.

Can you compile the kernel using the stock config and run addr2line on
the resultant vmlinux with the EIP (0x1a27869c) so we know what line
of source is causing this?
Comment 3 Bill Nottingham 2004-03-18 00:50:25 EST

*** This bug has been marked as a duplicate of 117713 ***
Comment 4 Jens Petersen 2004-03-22 00:03:58 EST
3d crashing seems to have stopped in kernel-2.6.3-2.1.253.2.1.
Comment 5 Jens Petersen 2004-03-22 01:32:54 EST
Errrm, oops, I take that back, at least when selinux=0.
Comment 6 Jens Petersen 2004-03-22 03:00:57 EST
Yeah, with enforcing=1 the crashing seems to happen much less.
Comment 7 Red Hat Bugzilla 2006-02-21 14:02:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.