Bug 1185544 - [abrt] PackageKit: hy_package_get_reponame(): packagekitd killed by SIGSEGV
Summary: [abrt] PackageKit: hy_package_get_reponame(): packagekitd killed by SIGSEGV
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0a2755695a1fba763c7739c265e...
: 1186465 1190332 1194402 1200589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-24 14:05 UTC by aboguckiy
Modified: 2015-06-21 00:06 UTC (History)
20 users (show)

Fixed In Version: gnome-software-3.14.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-21 00:06:50 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
File: backtrace (26.56 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: cgroup (200 bytes, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: core_backtrace (15.14 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: dso_list (11.65 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: environ (120 bytes, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: limits (1.29 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: maps (54.29 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: open_fds (1.92 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: proc_pid_status (909 bytes, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: var_log_messages (1.93 KB, text/plain)
2015-01-24 14:05 UTC, aboguckiy
no flags Details
File: exploitable (168 bytes, application/octet-stream)
2015-01-24 14:05 UTC, aboguckiy
no flags Details

Description aboguckiy 2015-01-24 14:05:03 UTC
Version-Release number of selected component:
PackageKit-1.0.4-1.fc21

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: hy_package_get_reponame
executable:     /usr/libexec/packagekitd
kernel:         3.17.8-300.fc21.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (9 frames)
 #0 hy_package_get_reponame at /usr/src/debug/hawkey/py3/src/package.c:306
 #1 hif_package_get_id at hif-package.c:254
 #2 hif_emit_package at hif-backend.c:51
 #3 hif_emit_package_array at hif-backend.c:85
 #4 pk_backend_transaction_simulate at pk-backend-hif.c:2165
 #5 pk_backend_transaction_run at pk-backend-hif.c:2314
 #6 pk_backend_install_files_thread at pk-backend-hif.c:3021
 #7 pk_backend_job_thread_setup at pk-backend-job.c:815
 #8 g_thread_proxy at gthread.c:764

Comment 1 aboguckiy 2015-01-24 14:05:07 UTC
Created attachment 983667 [details]
File: backtrace

Comment 2 aboguckiy 2015-01-24 14:05:08 UTC
Created attachment 983668 [details]
File: cgroup

Comment 3 aboguckiy 2015-01-24 14:05:10 UTC
Created attachment 983669 [details]
File: core_backtrace

Comment 4 aboguckiy 2015-01-24 14:05:11 UTC
Created attachment 983670 [details]
File: dso_list

Comment 5 aboguckiy 2015-01-24 14:05:12 UTC
Created attachment 983671 [details]
File: environ

Comment 6 aboguckiy 2015-01-24 14:05:14 UTC
Created attachment 983672 [details]
File: limits

Comment 7 aboguckiy 2015-01-24 14:05:16 UTC
Created attachment 983673 [details]
File: maps

Comment 8 aboguckiy 2015-01-24 14:05:17 UTC
Created attachment 983674 [details]
File: open_fds

Comment 9 aboguckiy 2015-01-24 14:05:19 UTC
Created attachment 983675 [details]
File: proc_pid_status

Comment 10 aboguckiy 2015-01-24 14:05:20 UTC
Created attachment 983676 [details]
File: var_log_messages

Comment 11 aboguckiy 2015-01-24 14:05:22 UTC
Created attachment 983677 [details]
File: exploitable

Comment 12 Kalev Lember 2015-03-14 15:10:36 UTC
*** Bug 1194402 has been marked as a duplicate of this bug. ***

Comment 13 Kalev Lember 2015-03-14 15:10:47 UTC
*** Bug 1190332 has been marked as a duplicate of this bug. ***

Comment 14 Kalev Lember 2015-03-14 15:11:00 UTC
*** Bug 1186465 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2015-03-28 22:46:58 UTC
PackageKit-1.0.5-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/PackageKit-1.0.5-2.fc22

Comment 17 Fedora Update System 2015-03-30 07:01:37 UTC
Package PackageKit-1.0.5-2.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing PackageKit-1.0.5-2.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-4971/PackageKit-1.0.5-2.fc22
then log in and leave karma (feedback).

Comment 18 Fedora Update System 2015-03-31 21:37:35 UTC
PackageKit-1.0.5-2.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Laurent Rineau 2015-05-11 20:20:03 UTC
The initial bug report was against Fedora 21.

Comment 20 Laurent Rineau 2015-05-14 13:57:10 UTC
The last build of PackageKit for Fedora 21 was, in January 2015, PackageKit-1.0.4-1.fc21, the version currently distributed in 'updates' for Fedora 21:
  https://admin.fedoraproject.org/updates/FEDORA-2015-0921
  http://koji.fedoraproject.org/koji/packageinfo?packageID=5206

Since then, nothing. Is Fedora 21 left behind on purpose?

Comment 21 Kamil Szmit 2015-05-16 07:33:39 UTC
Another user experienced a similar problem:

Error occurs when I tring to install http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm and http://dl.fedoraproject.org/pub/epel/5/x86_64/kyum-0.7.5-10.el5.x86_64.rpm with Apper program. Apper cannot install them and crashed later. Crash can have caused by automatic updates.

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: hy_package_get_reponame
executable:     /usr/libexec/packagekitd
kernel:         3.19.7-200.fc21.x86_64
package:        PackageKit-1.0.4-1.fc21
reason:         packagekitd killed by SIGSEGV
runlevel:       unknown
type:           CCpp
uid:            0

Comment 22 Kalev Lember 2015-05-29 15:08:42 UTC
*** Bug 1200589 has been marked as a duplicate of this bug. ***

Comment 23 cesar manuel lopez cadena 2015-05-31 02:20:40 UTC
Another user experienced a similar problem:

Al parecer sucedio mediante una actualizacion inconclusa... 

reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/libexec/packagekitd
crash_function: hy_package_get_reponame
executable:     /usr/libexec/packagekitd
kernel:         3.19.7-200.fc21.x86_64
package:        PackageKit-1.0.4-1.fc21
reason:         packagekitd killed by SIGSEGV
runlevel:       N 5
type:           CCpp
uid:            0

Comment 24 Fedora Update System 2015-06-08 21:48:33 UTC
gnome-software-3.14.5-2.fc21, PackageKit-1.0.6-1.fc21, libhif-0.2.0-3.fc21, libappstream-glib-0.4.0-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2015-9570/gnome-software-3.14.5-2.fc21,PackageKit-1.0.6-1.fc21,libhif-0.2.0-3.fc21,libappstream-glib-0.4.0-1.fc21

Comment 25 Fedora Update System 2015-06-10 19:18:48 UTC
Package gnome-software-3.14.5-2.fc21, PackageKit-1.0.6-1.fc21, libhif-0.2.0-3.fc21, libappstream-glib-0.4.0-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-software-3.14.5-2.fc21 PackageKit-1.0.6-1.fc21 libhif-0.2.0-3.fc21 libappstream-glib-0.4.0-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9570/gnome-software-3.14.5-2.fc21,PackageKit-1.0.6-1.fc21,libhif-0.2.0-3.fc21,libappstream-glib-0.4.0-1.fc21
then log in and leave karma (feedback).

Comment 26 Fedora Update System 2015-06-21 00:06:50 UTC
gnome-software-3.14.5-2.fc21, PackageKit-1.0.6-1.fc21, libhif-0.2.0-3.fc21, libappstream-glib-0.4.0-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.