Bug 118566 - multiple installed kernel .rpm confuse up2date
multiple installed kernel .rpm confuse up2date
Status: CLOSED DUPLICATE of bug 119933
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-17 15:21 EST by John Reiser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2004-03-17 15:21:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
If I have multiple kernels installed:
-----
$ rpm -qa | grep kernel
kernel-utils-2.4-9.1.123
kernel-2.6.3-2.1.253
kernel-2.6.3-2.1.246
kernel-2.6.2-1.81.perfctr2.6.5
kernel-2.6.3-2.1.242.jreiser
kernel-2.6.3-2.1.253.jreiser
kernel-2.6.3-2.1.246.jreiser
kernel-2.6.3-2.1.242
$ 
-----
then up2date GUI believes that I'm behind the times:
-----
  [newest] Version 2.6.3-2.1.253  Old Version 2.6.2-1.81.perfctr2.6.5
-----
even though I do have the latest installed, and in fact am running it:
-----
$ cat /proc/version
Linux version 2.6.3-2.1.253.jreiser (jreiser@fc2test1) (gcc version
3.3.3 20040216 (Red Hat Linux 3.3.3-2.1)) #1 Sat Mar 13 17:50:49 PST 2004
-----



Version-Release number of selected component (if applicable):
up2date-gnome-4.3.11-2.1.1

How reproducible:
Always

Steps to Reproduce:
1. Install multiple kernel versions.
2. Click on red '!' rhn-applet in panel, Forward to "confirm skip of
kernels" window, look at Available/Old versions.
3.
    

Actual Results:  It seems like the oldest installed kernel is the one
that is picked for comparison with the newest available kernel.

Expected Results:  The newest installed kernel should be compared with
the newest available kernel.

Additional info:
Comment 1 Adrian Likins 2004-04-07 16:38:40 EDT

*** This bug has been marked as a duplicate of 119933 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.