Bug 119933 - Wrong "Old Version" listed for kernel on up2date
Summary: Wrong "Old Version" listed for kernel on up2date
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bret McMillan
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
: 118566 (view as bug list)
Depends On:
Blocks: 120092
TreeView+ depends on / blocked
 
Reported: 2004-04-03 18:09 UTC by Brian "netdragon" Bober
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 4.4.x
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-29 14:51:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot that shows what I'm talking about (125.08 KB, image/png)
2004-04-03 18:11 UTC, Brian "netdragon" Bober
no flags Details

Description Brian "netdragon" Bober 2004-04-03 18:09:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040312

Description of problem:
The screenshot says it all. I have kernel 2.6.4-1.303 installed, and
it says "Old Version" is kernel-2.6.3-2.1.253.2.1

Version-Release number of selected component (if applicable):
up2date-4.3.11-2.1.1

How reproducible:
Always

Steps to Reproduce:
Have both kernels installed.

Actual Results:  Says "Old Version" is kernel-2.6.3-2.1.253.2.1

Expected Results:  Says "Old Version is 2.6.4-1.303

Comment 1 Brian "netdragon" Bober 2004-04-03 18:11:51 UTC
Created attachment 99090 [details]
Screenshot that shows what I'm talking about

Comment 2 Adrian Likins 2004-04-05 19:30:51 UTC
Hmm, yeah. The "old version" in the gui doesnt take
packages with multiple versions installed into
effect. 

I'll take a look. 

Comment 3 Adrian Likins 2004-04-07 20:38:42 UTC
*** Bug 118566 has been marked as a duplicate of this bug. ***

Comment 4 Ryan Bloom 2004-05-10 14:02:44 UTC
This is fixed in HEAD and ERRATA_RHEL3_U1.  AS2.1 doesn't actually
display the old version, so it wasn't fixed there.

If you have multiple versions of the same package on your box, up2date
will now always display the latest version in the GUI.

Comment 5 John Reiser 2004-06-01 21:22:48 UTC
In RHEL-3WS, up2date-4.2.16-1 (13-MAY-04) still has a related problem.
 I have:
-----
$ rpm -qa | grep kernel
kernel-2.4.21-9.0.1.EL
kernel-2.4.21-15.EL
kernel-2.4.21-9.0.1.EL.perfctr2.6.6
kernel-pcmcia-cs-3.1.31-13
kernel-2.4.21-9.0.3.EL
kernel-utils-2.4-8.37.5
kernel-smp-2.4.21-9.0.1.EL.perfctr2.6.6
$ 
-----
and in "Packages Flagged to be Skipped", graphical up2date still lists
-----
[Package]    [Version]      [Old Version]
kernel       2.4.21-15.EL   2.4.21-9.0.3.EL
kernel-smp   2.4.21-15.EL   2.4.21-9.0.1.EL
-----
which is confusing because kernel-2.4.21-15.EL [UniProcessor] is
already installed.  If I don't check the box to Skip
kernel-2.4.21-15.EL, then I get a large window (too tall to fit on the
screen) complaining that many files in 2.4.21-15.EL conflict with the
versions that are already installed from 2.4.21-15.EL.

I don't know whether the part that confuses up2date is not having
matching pairs of UP and SMP kernels with the same versions, or having
the set:
-----
kernel-2.4.21-9.0.1.EL
kernel-2.4.21-9.0.1.EL.perfctr2.6.6
kernel-2.4.21-9.0.3.EL
kernel-2.4.21-15.EL
-----
all installed at the same time.  Notice that the Old Version chosen by
up2date is the third one (9.0.3-EL).




Comment 6 John Thacker 2006-10-29 14:51:47 UTC
Should be fixed in all current releases of up2date, including on RHEL3


Note You need to log in before you can comment on or make changes to this bug.