Bug 118631 - autofs starts before slapd
Summary: autofs starts before slapd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-18 14:36 UTC by Neal Becker
Modified: 2014-08-31 23:26 UTC (History)
3 users (show)

Fixed In Version: openldap-2_2_23-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 17:02:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal Becker 2004-03-18 14:36:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
autofs starts before slapd.  If you use ldap for your mount maps this won't work.

Since autofs using ldap is standard, but having ldap depend on autofs is not, it is better to start slapd first.

Version-Release number of selected component (if applicable):
chkconfig-1.3.9-1.1

How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
    

Additional info:

Comment 1 lars 2004-03-24 13:09:06 UTC
I just got bit by this same problem.  It's a real PITA, too, since it causes all sorts of 
problems for user logins or other services that rely on automounted directories.  Given 
that LDAP is serving the same purpose as NIS in this situtation, the ldap script should 
probably start up around S26 just like the ypserv script.


Comment 2 Stephen Walton 2005-05-13 21:27:24 UTC
This is a dupe of bug 67753.

Comment 3 Jay Fenlason 2006-01-11 17:02:59 UTC
According to the CVS logs, this was fixed for Fedora Core 4 


Note You need to log in before you can comment on or make changes to this bug.