Bug 118697 - Running glxinfo on Intel i865 kills X server
Running glxinfo on Intel i865 kills X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
: 119026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-18 18:49 EST by Jeremy Katz
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-02 10:50:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log (48.55 KB, text/plain)
2004-03-18 18:50 EST, Jeremy Katz
no flags Details
GForce4 MX440 XFree86.0.log (36.33 KB, text/plain)
2004-03-20 17:50 EST, Bob Arendt
no flags Details
XFree86.0.log for ATI Rage mobility (38.20 KB, text/plain)
2004-03-23 12:32 EST, Paul Nasrat
no flags Details
XFree log for ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c) (36.50 KB, text/plain)
2004-03-28 20:07 EST, Thomas Molina
no flags Details

  None (edit)
Description Jeremy Katz 2004-03-18 18:49:11 EST
X server appears to sigabort.  Attaching various log files.

[root@localhost root]# rpm -q xorg-x11
xorg-x11-0.0.6.6-0.0.2004_03_11.5
[root@localhost root]# uname -a
Linux localhost.localdomain 2.6.3-2.1.253.2.1smp #1 SMP Fri Mar 12
14:23:36 EST 2004 i686 i686 i386 GNU/Linux
[root@localhost root]# /sbin/lspci
00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub
Interface (rev 02)
00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated
Graphics Device (rev 02)
00:03.0 PCI bridge: Intel Corp. 82865G/PE/P PCI to CSA Bridge (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI
#1 (rev 02)00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R)
USB UHCI #2 (rev 02)00:1d.2 USB Controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) USB UHCI #3 (rev 02)00:1d.3 USB Controller: Intel Corp.
82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)00:1d.7 USB Controller:
Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to
PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge
(rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA
100 Storage Controller (rev 02)
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150
Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller
(rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER
(ICH5/ICH5R) AC'97 Audio Controller (rev 02)
01:01.0 Ethernet controller: Intel Corp. 82547EI Gigabit Ethernet
Controller (LOM)
02:03.0 FireWire (IEEE 1394): Texas Instruments TSB43AB23
IEEE-1394a-2000 Controller (PHY/Link)


00:02.0 Class 0300: 8086:2572 (rev 02)
        Subsystem: 8086:4246
        Flags: bus master, fast devsel, latency 0, IRQ 169
        Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at ec00 [size=8]
pcilib: proc_read: tried to read 4 bytes at 208, but got only 0
        Capabilities: <available only to root>
Comment 1 Jeremy Katz 2004-03-18 18:50:11 EST
Created attachment 98670 [details]
X log
Comment 2 Pekka Pietikäinen 2004-03-20 09:08:16 EST
Same thing happens with a nvidia geforce 4 ti4200 using the 
nv driver (and non-proprietary libGL etc., so it should be using 
plain software MesaGL) 
 
01:00.0 Class 0300: 10de:0281 (rev a1) 
        Subsystem: 10b0:0406 
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR- FastB2B- 
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium 
>TAbort- <TAbort- <MAbort- >SERR- <PERR- 
        Latency: 64 (1250ns min, 250ns max) 
        Interrupt: pin A routed to IRQ 11 
        Region 0: Memory at ee000000 (32-bit, non-prefetchable) 
[size=effe0000] 
        Region 1: Memory at f0000000 (32-bit, prefetchable) 
[size=128M] 
        Expansion ROM at 00020000 [disabled] 
        Capabilities: [60] Power Management version 2 
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA 
PME(D0-,D1-,D2-,D3hot-,D3cold-) 
                Status: D0 PME-Enable- DSel=0 DScale=0 PME- 
        Capabilities: [44] AGP version 3.0 
                Status: RQ=32 Iso- ArqSz=0 Cal=3 SBA+ ITACoh- GART64- 
HTrans- 64bit- FW+ AGP3+ Rate=x4,x8 
                Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- 
FW- Rate=<none> 
 
Comment 3 Bob Arendt 2004-03-20 17:50:06 EST
Created attachment 98720 [details]
GForce4 MX440 XFree86.0.log
Comment 4 Bob Arendt 2004-03-20 18:03:05 EST
For minimalist example, I ran a bare XServer from runlevel 3:
startx /usr/X11R6/bin/xterm -bg wheat -- /usr/X11R6/bin/XFree86 -audit
0 -logverbose 15

.. then typed "glxinfo" in the xterm.  The Xserver crashed, leaving
me on console tty1.  tty1 was frozen (the dead Xserver still had the
keyboard).  I had to do a:

kill -3 2753  (XFree86 pid)

on the second console to regain control of the first console
and free the H/W resources.  After killing XFree86 manually,
X would still start normally via startx or going to runlevel 5.

Right after the server segv (as noted in the log) a "ps -ef" revealed:

UID        PID  PPID  C STIME TTY          TIME CMD
root      1564     1  0 15:32 ?        00:00:00 xfs -droppriv -daemon
root      1617  1611  0 15:32 tty1     00:00:00 -bash
root      2740  1617  0 15:47 tty1     00:00:00 /bin/sh
/usr/X11R6/bin/startx /usr/X11R6/bin/xterm -bg wheat --
/usr/X11R6/bin/XFree86 -audit 0 -logverbose 15
root      2752  2740  0 15:47 tty1     00:00:00 xinit
/usr/X11R6/bin/xterm -bg wheat -- /usr/X11R6/bin/XFree86 -audit 0
-logverbose 15
root      2753  2752  0 15:47 ?        00:00:00 /usr/X11R6/bin/XFree86
:0 -audit 0 -logverbose 15
root      2757  2752  0 15:47 tty1     00:00:00 /usr/X11R6/bin/xterm
-bg wheat
root      2759  2757  0 15:47 pts/1    00:00:00 bash
root      2783  2759  0 15:47 pts/1    00:00:00 glxinfo


Comment 5 Paul Nasrat 2004-03-23 12:32:45 EST
Created attachment 98793 [details]
XFree86.0.log for ATI Rage mobility

Same occuring here on:

01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP
2x (rev 64)

Kills my laptop display untill a reboot.
Comment 6 Mark Heslep 2004-03-24 13:20:25 EST
Same for me on Radeon (ATI Fire GL).  Crashes w/ glxinfo, immediately,
and every time.  No tty's available either.  using xorg from
development 3/23
Comment 7 Thomas Molina 2004-03-28 20:07:41 EST
Created attachment 98914 [details]
XFree log for ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)

This happened both with the XFree86 originally in the distro as well as the
upgraded x11-org server now current.  I have watched the screensaver for as
much as an hour without it happening, but if I leave it overnight, eventually
the X server locks up.	As with others, running the glxinfo command makes it
happen immediately.  This happens both with the Fedora "stock" kernels as well
as with a plain jane Linus kernel fresh from bitkeeper.
Comment 8 Mike A. Harris 2004-03-29 15:35:07 EST
The problem reported by Jeremy Katz above is an Intel i865 specific
problem, or at least an i810 driver specific problem.

While other people are also having SEGV issues, the other SEGV issues
being reported are not the same bug/problem.  Please file separate
bug reports for SEGV/Fatal error 11 bugs experienced on other hardware.

Also try running with "selinux=0" to see if that resolves the
problems.

I thought I'd mention the above, as this bug is tracking the i865
issue only, and if others are having SEGVs in other drivers/hardware,
those issues should be reported and tracked individually.

Thanks in advance.
Comment 9 Mike A. Harris 2004-03-29 15:36:37 EST
Also, please try:

echo 0 > /proc/sys/kernel/exec-shield

xorg-x11 is not compatible with exec-shield currently.
Comment 10 John Dennis 2004-03-29 18:34:06 EST
I just tracked down a bug in that would cause a SEGV anytime someone
called glGetString(GL_VERSION), which glxinfo and probably many of the
3D screen savers would call. 

http://pdx.freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=385

I'm pretty sure this is the root cause, although I happened to stumble
across this while trying to enable our exec shield patches. For what
its worth, the two issues are unrelated.

BTW, it appears this bug has been around for a while in the glx
sources, I think the only reason its showing up now may be because of
a new malloc implementation.

I have a patch for this problem and will take ownership of this bug.
Comment 11 John Dennis 2004-03-29 18:45:10 EST
*** Bug 119026 has been marked as a duplicate of this bug. ***
Comment 12 Jim McElwaine 2004-03-30 08:06:19 EST
I have similar problems with i810
I'm running most update version of Fedora test
glxinfo has no problems
I can give you logs if this is helpful
Comment 13 Bob Arendt 2004-04-02 00:26:03 EST
My glxinfo segv went away with todays xorg-x11-0.0.6.6-0.0.2004_03_11.11
So I won't create a seperate bug against "nv" & glx. Thanks!
Comment 14 John Dennis 2004-04-02 10:50:02 EST
I'm closing this bug as we believe the problem the bug was originally
was opened for is now fixed. However, it's not clear to me if some
other  unrelated issues haven't been added here. If you believe you're
still experiencing some other problem unrelated to glxinfo or
glGetString(GL_VERSION) please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.