Bug 1187328 - PPTP connection not working with kernel 3.18 (without nf_conntrack_pptp)
Summary: PPTP connection not working with kernel 3.18 (without nf_conntrack_pptp)
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1192744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-29 19:12 UTC by azgarech
Modified: 2015-12-02 17:15 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-02 08:14:05 UTC


Attachments (Terms of Use)

Description azgarech 2015-01-29 19:12:40 UTC
Description of problem:

I use my Fedora box to connect to a pptp vpn server, using the pptp NetworkManager plugin. This worked perfectly until yesterday, but upgrading to the latest 3.18.3-201 kernel breaks the feature. I cannot connect anymore: connection process ends with timeout.

Restarting the computer with the previous kernel (3.17.8-300) permits vpn-pptp connection again.

So I guess the problem is linked to the 3.18 kernel.

Version-Release number of selected component (if applicable):


How reproducible:
Update to the last Kernel And try a connection to a pptp vpn


Steps to Reproduce:
1.Update kernel
2.Try to Connect to a pptp VPN
3.

Actual results:

Connection timed out


Expected results:


Additional info:

Restarting the computer with the previous kernel (3.17.8-300) permits vpn-pptp connection again.

Comment 1 Mihkel Vain 2015-01-31 11:18:33 UTC
I'm having the same problem. With kernel version 3.18.3 I can't connect to pptp vpn, but with 3.17.8 I can. I have not tried older kernel version though.

Comment 2 Mihkel Vain 2015-01-31 13:08:14 UTC
I did some digging and I thought I just drop it here too :)
In kernels 3.18 or higher nf_conntrack_pptp has to be loaded in order to use pptp vpn. So the solution so far is to either load mentioned module or create a conf file under /etc/modules-load.d/ with nf_conntrack_pptp as it content.

Comment 3 azgarech 2015-01-31 19:04:45 UTC
Thanks for the Feedback guys. 

I gonna write back how to fix it.

To Start the module manually do 

#sudo modprobe nf_conntrack_pptp

To automaticly launch the module on boot

#sudo touch /etc/modules-load.d/nf_conntrack_pptp.conf
#sudo echo "nf_conntrack_pptp" > /etc/modules-load.d/nf_conntrack_pptp.conf

Comment 4 Jirka Klimes 2015-02-01 13:23:41 UTC
Indeed, this seems like a change in kernel. Re-assigning to get kernel developers opinion. 

http://markmail.org/message/wcdckxmhbgjx5lg7

Comment 5 Daniele Viganò 2015-02-03 12:09:37 UTC
Confirmed. modprobe nf_conntrack_pptp fixes the issue, but it needs to be loaded manually.

Comment 6 David 2015-02-10 12:59:37 UTC
Confirmed that sudo modprobe nf_conntrack_pptp fixes the issue.  This issue exists on Kernel 3.18.3.201 and 3.18.5.201

Comment 7 gofmanp 2015-02-16 12:00:30 UTC
Confirmed that the issue exists on Kernel 3.18.6-200. modprobe nf_conntrack_pptp fixes the issue.

Comment 8 Josh Boyer 2015-02-17 13:44:27 UTC
*** Bug 1192744 has been marked as a duplicate of this bug. ***

Comment 9 Mo Morsi 2015-02-17 22:25:28 UTC
+1 works for me

Comment 10 Ken Smith 2015-03-26 15:59:57 UTC
This issue also arises in RHEL 6 (& Centos6) kernel 2.6.32-504.12.2.el6.x86_64

Is noting it here sufficient for a fix in the RHEL development?

Comment 11 Josh Boyer 2015-03-26 16:08:56 UTC
No, please file a bug against the RHEL component (and Centos if you'd like).

Comment 12 Ken Smith 2015-03-26 17:15:03 UTC
Logged as Bug 1206276 in RHEL

Comment 13 Jirka Klimes 2015-04-28 13:58:38 UTC
The nf_conntrack_pptp module is now loaded automatically by nm-pptp-service, see bug 1214643.

Comment 14 Fedora Kernel Team 2015-04-28 18:29:30 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 21 kernel bugs.

Fedora 21 has now been rebased to 3.19.5-200.fc21.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 22, and are still experiencing this issue, please change the version to Fedora 22.

If you experience different issues, please open a new bug report for those.

Comment 15 Bas Mevissen 2015-04-28 22:22:54 UTC
The update to 3.19.5-200.fc21 has not made a change to this bug.
However, as noted in comment c13, the issue is resolved in user space. It only awaits a fix for FC20 and RHEL. FC21 and FC22 fixes are available.

I think it can be closed now.

Comment 16 Fedora End Of Life 2015-11-04 12:17:24 UTC
This message is a reminder that Fedora 21 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 21. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '21'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 21 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 17 Fedora End Of Life 2015-12-02 08:14:17 UTC
Fedora 21 changed to end-of-life (EOL) status on 2015-12-01. Fedora 21 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.