Bug 1192744 - vpn ceaed to work on vmlinuz-3.18.6-100.fc20.i686
Summary: vpn ceaed to work on vmlinuz-3.18.6-100.fc20.i686
Keywords:
Status: CLOSED DUPLICATE of bug 1187328
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-14 22:55 UTC by Peter Lucas
Modified: 2015-02-17 13:44 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 13:44:27 UTC


Attachments (Terms of Use)

Description Peter Lucas 2015-02-14 22:55:19 UTC
Description of problem:

When I start vpn from NetworkManager on kernel 3.18.6-100.fc20.i686, it is
unable to establish a connection. When I switch back to kenel vmlinuz-3.17.8-200.fc20.i686 a connection is made. This is the only difference
between the environment; versions of all the other software are exactly
the same.

Version-Release number of selected component (if applicable):

vmlinuz-3.18.6-100.fc20.i686

How reproducible:

Try to establish a vpn connection through NetworkManager

Steps to Reproduce:
1. vpn connection through NetworkManager using vmlinuz-3.18.6-100.fc20.i686
2. restart using vmlinuz-3.17.8-200.fc20.i686
3. vpn connection through NetworkManager using vmlinuz-3.17.8-200.fc20.i686

Actual results:

1: no vpn connection; 3: working vpn connection 

Expected results:

This is using kernel vmlinuz-3.18.6-100.fc20.i686:
Additional info:
Feb 14 23:50:42 localhost pppd[1891]: Connect: ppp0 <--> /dev/pts/1
Feb 14 23:50:42 localhost NetworkManager: Connect: ppp0 <--> /dev/pts/1
Feb 14 23:50:42 localhost NetworkManager: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 5 / phase 'establish'
Feb 14 23:50:42 localhost pptp[1893]: nm-pptp-service-1887 log[main:pptp.c:333]: The synchronous pptp option is NOT activated
Feb 14 23:50:42 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 1 'Start-Control-Connection-Request'
Feb 14 23:50:42 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_disp:pptp_ctrl.c:758]: Received Start Control Connection Reply
Feb 14 23:50:42 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_disp:pptp_ctrl.c:792]: Client connection established.
Feb 14 23:50:43 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 7 'Outgoing-Call-Request'
Feb 14 23:50:43 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_disp:pptp_ctrl.c:877]: Received Outgoing Call Reply.
Feb 14 23:50:43 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_disp:pptp_ctrl.c:916]: Outgoing call established (call ID 0, peer's call ID 38912).
Feb 14 23:51:13 localhost pppd[1891]: LCP: timeout sending Config-Requests
Feb 14 23:51:13 localhost pppd[1891]: Connection terminated.
Feb 14 23:51:13 localhost avahi-daemon[484]: Withdrawing workstation service for ppp0.
Feb 14 23:51:13 localhost NetworkManager: LCP: timeout sending Config-Requests
Feb 14 23:51:13 localhost NetworkManager: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 11 / phase 'disconnect'
Feb 14 23:51:13 localhost NetworkManager: Connection terminated.
Feb 14 23:51:13 localhost pppd[1891]: Modem hangup
Feb 14 23:51:13 localhost pptp[1893]: nm-pptp-service-1887 warn[decaps_hdlc:pptp_gre.c:220]: short read (-1): Input/output error
Feb 14 23:51:13 localhost pptp[1893]: nm-pptp-service-1887 warn[decaps_hdlc:pptp_gre.c:232]: pppd may have shutdown, see pppd log
Feb 14 23:51:13 localhost pppd[1891]: Exit.
Feb 14 23:51:13 localhost pptp[1900]: nm-pptp-service-1887 log[callmgr_main:pptp_callmgr.c:245]: Closing connection (unhandled)
Feb 14 23:51:13 localhost pptp[1900]: nm-pptp-service-1887 log[ctrlp_rep:pptp_ctrl.c:258]: Sent control packet type is 12 'Call-Clear-Request'
Feb 14 23:51:13 localhost pptp[1900]: nm-pptp-service-1887 log[call_callback:pptp_callmgr.c:84]: Closing connection (call state)
Feb 14 23:51:13 localhost NetworkManager: ** Message: nm-pptp-ppp-plugin: (nm_phasechange): status 1 / phase 'dead'
Feb 14 23:51:13 localhost NetworkManager: Modem hangup
Feb 14 23:51:13 localhost NetworkManager: ** Message: nm-pptp-ppp-plugin: (nm_exit_notify): cleaning up
Feb 14 23:51:13 localhost NetworkManager: ** (nm-pptp-service:1887): WARNING **: pppd exited with error code 16
Feb 14 23:51:13 localhost NetworkManager[613]: <warn> VPN plugin failed: connect-failed (1)
Feb 14 23:51:13 localhost NetworkManager[613]: <warn> VPN plugin failed: connect-failed (1)
Feb 14 23:51:13 localhost NetworkManager[613]: <warn> VPN plugin failed: connect-failed (1)
Feb 14 23:51:13 localhost NetworkManager[613]: <info> VPN plugin state changed: stopped (6)
Feb 14 23:51:13 localhost NetworkManager[613]: <info> VPN plugin state change reason: unknown (0)
Feb 14 23:51:13 localhost NetworkManager[613]: <warn> error disconnecting VPN: Could not process the request because no VPN connection was active.
Feb 14 23:51:18 localhost NetworkManager[613]: <info> VPN service 'pptp' disappeared

Comment 1 Josh Boyer 2015-02-16 14:08:19 UTC
If you run modprobe nf_conntrack_pptp as root or via sudo before you start the VPN, does it work?

Comment 2 Peter Lucas 2015-02-16 21:01:44 UTC
Yes, this solves the problem. So I was right that it has something to do with
the new kernel.

Peter

Comment 3 Josh Boyer 2015-02-17 13:44:27 UTC

*** This bug has been marked as a duplicate of bug 1187328 ***


Note You need to log in before you can comment on or make changes to this bug.