Bug 118734 - xrender.pc isn't in xorg-x11-devel-0.0.6.6-0.0.2004_03_11.6
xrender.pc isn't in xorg-x11-devel-0.0.6.6-0.0.2004_03_11.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 121698 (view as bug list)
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-19 12:26 EST by sangu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 22:58:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2004-03-19 12:26:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040312 Epiphany/1.2.0

Description of problem:
#pkg-config --modversion xrander
Package xrander was not found in the pkg-config search path.
Perhaps you should add the directory containing `xrander.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xrander' found


Version-Release number of selected component (if applicable):
xorg-x11-devel-0.0.6.6-0.0.2004_03_11.6

How reproducible:
Always

Steps to Reproduce:
1. xrander isn't in /usr/lib/pkgconfig
2.#pkg-config --list-all 
3. Package 'xrender', required by 'Xcursor', not found

    

Additional info:
Comment 1 Mike A. Harris 2004-03-22 20:43:09 EST
xrender.pc is created by GNU autotools when building libXrender
from the upstream sources outside of an XFree86/Xorg build, however
it is not created (never has been) when Xrender is built by Imake
inside the X build tree.

I've done some very ugly hacks in the past to try to accomodate
xrender.pc (and xft.pc also), but they're not very reliable, in
particular when these libraries get updated.

The best solution for this problem, will be when we split Xft
and Xrender out into their own separate packages.  Possibly for
FC2test3.

Comment 2 sangu 2004-03-22 22:00:54 EST
Please see http://www.kde.gr.jp/~akito/patch/fontconfig/xft-2.1.1/ for
cjk users.
Comment 3 Mike A. Harris 2004-03-22 22:12:46 EST
I'm not quite sure how the patches at the URL in comment #2 relate
to the xrender.pc file missing, however if there are any enhancements
for Xft which you'd like to see included, please submit the patches
directly to the upstream Xft development by filing an enhancement
bug report at http://bugs.freedesktop.org against the Xft component.

Once your enhancements are accepted by the upstream Xft developers
and included in an official release of libXft, it will eventually
appear in a future Red Hat Xft build.

Comment 4 sangu 2004-03-22 22:30:58 EST
"when we split Xft
and Xrender out into their own separate packages." - Please add
makebold patch.

Already bug reported :
http://freedesktop.org/cgi-bin/bugzilla/show_bug.cgi?id=102

I'm sorry that my comments isn't proper. 
Comment 5 Mike A. Harris 2004-03-22 22:44:53 EST
I won't add the makebold patch referenced above to our libXft,
as that would make it differ significantly from upstream libXft, and
the support maintenance burden for libXft would then fall entirely
on Red Hat.

However, if the makebold patch is considered safe and sane by the
upstream Xft developers, they might include it in a future release
of libXft.  If that happens, then this feature will be included in
a future Red Hat OS release once we integrate the upstream libXft
into the distribution which contains this new feature.

Comment 6 Kristian Høgsberg 2004-07-12 15:50:06 EDT
*** Bug 121698 has been marked as a duplicate of this bug. ***
Comment 7 sangu 2004-08-10 22:58:13 EDT
This problem was fixed in xorg-x11-devel-6.7.99.0-0.2004_08_05.1.

Note You need to log in before you can comment on or make changes to this bug.