Bug 1187374 - Inconsistency in wording on HTTP vs HTTPS enable flags in Repo screens
Summary: Inconsistency in wording on HTTP vs HTTPS enable flags in Repo screens
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.7
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Jitendra Yejare
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
: 1191628 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-01-29 22:15 UTC by Mike McCune
Modified: 2019-09-25 21:28 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:47:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (113.61 KB, image/png)
2015-01-29 22:15 UTC, Mike McCune
no flags Details
Failed QA - Screenshot (183.21 KB, image/png)
2015-09-03 12:57 UTC, Jitendra Yejare
no flags Details
Verified Screenshot (182.98 KB, image/png)
2015-09-07 09:14 UTC, Jitendra Yejare
no flags Details


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11627 None None None 2016-04-22 16:59:10 UTC
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Mike McCune 2015-01-29 22:15:33 UTC
Created attachment 985792 [details]
screenshot

In the Satellite 6 GUI Repository details screen, there are two headings:

* Publish via HTTPS: True
* Publish via HTTP: Yes

These need to both say either Yes/No or True/False

See screenshot attached.

Comment 1 Steve Loranz 2015-01-30 15:46:25 UTC
Do you have a preference for either one? (Yes/No vs True/False)

Seems like something Red Hat should have in some sort of human interface guidelines.

Comment 3 Brad Buckingham 2015-08-31 20:44:06 UTC
Created redmine issue http://projects.theforeman.org/issues/11627 from this bug

Comment 4 Bryan Kearney 2015-09-01 20:02:54 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11627 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|f74d548fe1603910720216d2abe498b9057ea4ed.

Comment 5 Jitendra Yejare 2015-09-03 12:34:21 UTC
Tested this on Upstream build. The issue is still reproducible.

Screenshot attached.

Comment 6 Jitendra Yejare 2015-09-03 12:42:59 UTC
Versions:
ruby193-rubygem-katello-2.4.0-1.nightly.201508250010gitbbcea20.el7.noarch

Comment 7 Jitendra Yejare 2015-09-03 12:49:15 UTC
Versions:
ruby193-rubygem-katello-2.4.0-1.nightly.201508250010gitbbcea20.el7.noarch
foreman-1.10.0-0.develop.201508241946git8658fa3.el7.noarch

Comment 8 Jitendra Yejare 2015-09-03 12:57:58 UTC
Created attachment 1069802 [details]
Failed QA - Screenshot

Comment 9 Brad Buckingham 2015-09-03 13:10:25 UTC
The current upstream build doesn't include the fix.  It appears that the upstream nightly hasn't been built for a while.  This is the build upstream: http://koji.katello.org/koji/buildinfo?buildID=24171

Comment 10 Brad Buckingham 2015-09-04 16:12:26 UTC
*** Bug 1191628 has been marked as a duplicate of this bug. ***

Comment 11 Jitendra Yejare 2015-09-07 09:12:55 UTC
Verified in latest upstream build.

Both,
Publish via HTTPS and 
Publish via HTTP,
has displayed 'Yes'/'No'.

Screenshot attached.

Comment 12 Jitendra Yejare 2015-09-07 09:14:11 UTC
Created attachment 1070870 [details]
Verified Screenshot

Comment 17 errata-xmlrpc 2016-07-27 08:47:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.