Bug 118745 - Unzip cannot create files > 2GB
Summary: Unzip cannot create files > 2GB
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: unzip (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords: Reopened
: 123890 (view as bug list)
Depends On:
Blocks: 190430
TreeView+ depends on / blocked
 
Reported: 2004-03-19 18:44 UTC by Rob Riggs
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 22:55:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Riggs 2004-03-19 18:44:44 UTC
Description of problem:
Unzip does not appear to be "large file" enabled.

Version-Release number of selected component (if applicable):
AS3u1
unzip-5.50-34

How reproducible:
Every time

Steps to Reproduce:
1. Create large file
2. Create a ZIP archive of the large file with an ZIP application that
can read large files
3. Attempt to unzip the newly created ZIP file under AS3u1
  
Actual results:

$unzip ~/test.zip
Archive:  /home/robr/test.zip
  inflating: test
test:  write error (disk full?).  Continue? (y/n/^C)

The size of the file up until the point of failure is 2147483647
bytes.  There is plenty of free disk space availabe when this fails.

Expected results:

Success and a large file written

Additional info:

"unzip -p ~/test.zip > test.1" can be used to work around the problem
-rw-r--r--    1 robr     devel    2276790208 Mar 19 11:33 test.1

Comment 2 Suzanne Hillman 2004-03-19 22:13:29 UTC
Internal RFE bug #114306 already exists for this.

Comment 3 Lon Hohberger 2004-05-21 13:15:54 UTC
*** Bug 123890 has been marked as a duplicate of this bug. ***

Comment 4 Lon Hohberger 2004-06-23 14:40:35 UTC
Try rebuilding or using the version from rawhide:

unzip-5.51-4
------------
* Mon Jun 21 2004 Lon Hohberger <lhh@redhat.com> 5.51-4

- Extend max file/archive size to 2^32-8193 (4294959103) bytes

http://download.fedora.redhat.com/pub/fedora/linux/core/development/SRPMS/unzip-5.51-4.src.rpm


Note You need to log in before you can comment on or make changes to this bug.