Bug 1187456 - Performance enhancement for RDMA
Summary: Performance enhancement for RDMA
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: mainline
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1186127
Blocks: 1202212
TreeView+ depends on / blocked
 
Reported: 2015-01-30 05:08 UTC by Mohammed Rafi KC
Modified: 2015-05-14 17:45 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.7.0
Doc Type: Bug Fix
Doc Text:
Clone Of: 1186127
: 1202212 (view as bug list)
Environment:
Last Closed: 2015-05-14 17:29:03 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Mohammed Rafi KC 2015-01-30 05:08:25 UTC
+++ This bug was initially created as a clone of Bug #1186127 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Anand Avati 2015-01-30 05:12:39 UTC
REVIEW: http://review.gluster.org/9506 (rdma: pre-register iobuf_pool with rdma devices.) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Anand Avati 2015-02-17 14:50:59 UTC
REVIEW: http://review.gluster.org/9506 (rdma: pre-register iobuf_pool with rdma devices.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 3 Anand Avati 2015-02-17 15:57:52 UTC
REVIEW: http://review.gluster.org/9506 (rdma: pre-register iobuf_pool with rdma devices.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)

Comment 4 Anand Avati 2015-02-18 04:10:03 UTC
COMMIT: http://review.gluster.org/9506 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit abcb2017b07b0706aef0d9eeb729115ca605ad6d
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Feb 17 20:17:58 2015 +0530

    rdma: pre-register iobuf_pool with rdma devices.
    
    registring buffers with rdma device is a time consuming
    operation. So performing registration in code path will
    decrease the performance.
    Using a pre registered memory will give a bettor performance,
    ie, register iobuf_pool during rdma initialization. For
    dynamically created arena, we can register with all the
    device.
    
    Change-Id: Ic79183e2efd014c43faf5911fdb6d5cfbcee64ca
    BUG: 1187456
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9506
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Anand Avati 2015-02-19 11:47:49 UTC
REVIEW: http://review.gluster.org/9697 (rdma: Free resources related to iobuf in fini) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 6 Anand Avati 2015-02-19 13:55:33 UTC
REVIEW: http://review.gluster.org/9697 (rdma: Free resources related to iobuf in fini) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)

Comment 7 Anand Avati 2015-03-11 02:28:40 UTC
COMMIT: http://review.gluster.org/9697 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 219512c5014e9a13081d6a9981ae02b54586d801
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Feb 19 15:52:28 2015 +0530

    rdma: Free resources related to iobuf in fini
    
    If rdma transport is destroyed because of any reason,
    then rdma.so will be unloaded. But we are not setting
    iobuf registeration function to null. After this, if
    an iobuf request is came, then we will try to call a
    function which is not loaded.
    
    Change-Id: I3293f9974e16d8e865131785ee697ea02be8cdfc
    BUG: 1187456
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/9697
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>

Comment 8 Niels de Vos 2015-05-14 17:29:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 9 Niels de Vos 2015-05-14 17:35:49 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 10 Niels de Vos 2015-05-14 17:38:11 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Comment 11 Niels de Vos 2015-05-14 17:45:47 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.0, please open a new bug report.

glusterfs-3.7.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/10939
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.