Bug 1187579 - dnf upgrade ./<TAB> doesn't autocomplete
dnf upgrade ./<TAB> doesn't autocomplete
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-01-30 07:58 EST by Jaroslav Škarvada
Modified: 2015-05-08 03:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 14:48:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Škarvada 2015-01-30 07:58:10 EST
Description of problem:
# dnf install powertop
# rpm -q powertop
powertop-2.7-1.fc21.x86_64
# dnf install ./powertop-2.7-2.fc22.x86_64.rpm 
Package powertop-2.7-1.fc21.x86_64 is already installed, skipping.
Error: Nothing to do.

# dnf upgrade ./po<TAB>
Nothing is auto-completed

On the other hand:
# rpm -q powertop
powertop-2.7-1.fc21.x86_64
# yum install ./powertop-2.7-2.fc22.x86_64.rpm 
Loaded plugins: auto-update-debuginfo, langpacks
Examining ./powertop-2.7-2.fc22.x86_64.rpm: powertop-2.7-2.fc22.x86_64
Marking ./powertop-2.7-2.fc22.x86_64.rpm as an update to powertop-2.7-1.fc21.x86_64
Resolving Dependencies
--> Running transaction check
---> Package powertop.x86_64 0:2.7-1.fc21 will be updated
---> Package powertop.x86_64 0:2.7-2.fc22 will be an update
--> Finished Dependency Resolution
...

# yum upgrade ./po<TAB>
Auto completed

Version-Release number of selected component (if applicable):
dnf-0.6.3-2.fc21.noarch

How reproducible:
Always

Steps to reproduce:
See above

Additional info:
I think that "dnf upgrade ./" should auto-complete the same way as "dnf update ./" and "yum update/upgrade ./" do.

I think that the "dnf install ./" could update/downgrade/reinstall the package automatically as in yum. It would save me of thinking whether it is upgrade/downgrade/reinstall. As it is local RPM, it is apparent that I want to replace the current package by it, so I think it is redundant to specify whether it is update/downgrade/reinstall.
Comment 1 Radek Holy 2015-01-30 09:34:56 EST
Hi Jaroslav,

thank you for the report. This is a duplicate of a bug #1138700.

Let me change this bug to track the bash completion problem.
Comment 2 Radek Holy 2015-02-09 09:34:03 EST
(In reply to Radek Holy from comment #1)
> This is a duplicate of a bug #1138700.

Rather bug 1160950.
Comment 3 Fedora Update System 2015-03-31 14:17:42 EDT
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
Comment 4 Fedora Update System 2015-04-01 21:43:59 EDT
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2015-04-03 07:39:04 EDT
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
Comment 6 Fedora Update System 2015-04-06 14:48:49 EDT
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-04-16 05:05:19 EDT
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21
Comment 8 Fedora Update System 2015-05-08 03:33:20 EDT
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.