Bug 118774 - Exception when saving configuration for a 2nd eth interface
Exception when saving configuration for a 2nd eth interface
Status: CLOSED DUPLICATE of bug 59017
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: redhat-config-network (Show other bugs)
2.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-19 19:09 EST by Daniel King
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel King 2004-03-19 19:09:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9)
Gecko/20020501

Description of problem:
After updating and saving a 2nd eth interface in
redhat-config-network, the application throws an exception when I try
to save the results.  It displays a dialog box with details about the
exception, and a request that I submit the exception to bugzilla.

Version-Release number of selected component (if applicable):
redhat-config-network-0.9.10-2.1


How reproducible:
Always

Steps to Reproduce:
1.start redhat-config-network
2.go to eth1, Edit
3.select the Protocols tab, then Edit
4. turn off DHCP, add IP address, subnet, and gateway,
5. then close, and exception occurs.
    

Actual Results:  An exception.  See below.

Expected Results:  I expect redhat-config-network to save the results,
instead of crashing.

Additional info:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in
__call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File
"/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py",
line 981, in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py",
line 936, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 85a8788>
varname: eth1
missing: 1
key: alias
place: 0
findexp: [	 ]*alias[	 ]+eth1[	 ]+
Comment 1 Harald Hoyer 2004-03-24 04:46:55 EST
An errata has been issued which should help the problem described in
this bug report. 
This report is therefore being closed with a resolution of ERRATA. For
more information
on the solution and/or where to find the updated files, please follow
the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html

*** This bug has been marked as a duplicate of 59017 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.