Bug 59017 - TB Conf:936:__setitem__
TB Conf:936:__setitem__
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 52145 63045 63608 71171 74835 77909 78618 81398 83955 98900 107355 114783 118774 (view as bug list)
Depends On:
Blocks: rcn-7.3
  Show dependency treegraph
 
Reported: 2002-01-29 08:01 EST by Phil Dunn
Modified: 2008-05-01 11:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-26 11:51:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log file from crash on 7.3 (1.90 KB, text/plain)
2003-02-04 18:16 EST, Larry Webber
no flags Details

  None (edit)
Description Phil Dunn 2002-01-29 08:01:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
When saving changes to the network config dialogue an exception occurs

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.open network config tool
2.make a change
3.press apply
	

Actual Results:  Exception Occured
Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 392, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCHardwareList.py",
line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 981,
in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", line 936,
in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation


Additional info:
Comment 1 Trond Eivind Glomsrxd 2002-01-30 18:56:45 EST
Which version?
Comment 2 general 2002-02-10 23:51:28 EST
I getting the same error but don't know how to find the version of the App. When
I do more it says Copyright 2001.
Comment 3 Trond Eivind Glomsrxd 2002-02-10 23:56:27 EST
rpm -q redhat-config-network
Comment 4 Phil Dunn 2002-02-11 07:29:03 EST
rpm -q redhat-config-network gives version 0.9.10-2
Comment 5 Harald Hoyer 2002-02-20 10:47:15 EST
please attach your /etc/modules.conf
Comment 6 Need Real Name 2002-03-18 04:09:35 EST
I also saw this exact same error on my own computer today.

The traceback was identical and it happened when I tried to apply a
configuration of a static IP address on an interface previously occupied by a
DHCP conf.

Here is my info:
[sahai@localhost ~]# rpm -q redhat-config-network
redhat-config-network-0.9.10-2

[sahai@localhost ~]# cat /etc/modules.conf
alias parport_lowlevel parport_pc
alias eth0 eepro100
alias usb-controller usb-uhci
alias sound-slot-0 i810_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1
|| :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
# alias eth1 wavelan2_cs
alias eth1 orinoco_cs
Comment 7 Harald Hoyer 2002-06-26 10:01:53 EDT
*** Bug 63045 has been marked as a duplicate of this bug. ***
Comment 8 Harald Hoyer 2002-06-26 10:03:18 EDT
should be fixed in 7.3
Comment 9 Harald Hoyer 2002-06-26 10:17:23 EDT
*** Bug 63608 has been marked as a duplicate of this bug. ***
Comment 10 Harald Hoyer 2002-06-26 10:47:33 EDT
*** Bug 52145 has been marked as a duplicate of this bug. ***
Comment 11 Harald Hoyer 2002-10-23 05:55:00 EDT
first beta of erratum is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.1-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.1 version... Thx
and please test.
Comment 12 Harald Hoyer 2002-11-20 12:31:11 EST
*** Bug 71171 has been marked as a duplicate of this bug. ***
Comment 13 Harald Hoyer 2002-11-20 12:32:28 EST
*** Bug 74835 has been marked as a duplicate of this bug. ***
Comment 14 Harald Hoyer 2002-11-27 05:49:18 EST
*** Bug 78618 has been marked as a duplicate of this bug. ***
Comment 15 Harald Hoyer 2003-01-09 04:48:33 EST
*** Bug 81398 has been marked as a duplicate of this bug. ***
Comment 16 Harald Hoyer 2003-01-09 04:51:15 EST
third beta of erratum for 7.3/7.2/AS2 is available at:
ftp://people.redhat.com/harald/redhat-config-network/1.0.3-1/

Most of the bugs reported have been removed, but as in every software change,
there could be new bugs introduced.

Please report bugs against this with explicitly stating the 1.0.3 version... Thx
and please test.

Comment 17 Larry Webber 2003-02-04 18:16:41 EST
Created attachment 89849 [details]
log file from crash on 7.3
Comment 18 Larry Webber 2003-02-04 18:20:15 EST
It's not clear to me from this ticket whether this bug should still exist in RH
7.3 or not. I am seeing very similar bug and sent a log of the results generated
when the utility crashes. This is similar but not identical to the message at
top of this ticket. I am running RH 7.3 however.
Comment 19 Harald Hoyer 2003-02-07 07:48:40 EST
*** Bug 77909 has been marked as a duplicate of this bug. ***
Comment 20 Harald Hoyer 2003-02-10 10:13:48 EST
*** Bug 83955 has been marked as a duplicate of this bug. ***
Comment 21 John Flanagan 2003-02-14 16:04:15 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2002-267.html
Comment 22 Harald Hoyer 2003-07-10 05:11:12 EDT
*** Bug 98900 has been marked as a duplicate of this bug. ***
Comment 23 Harald Hoyer 2003-10-21 07:59:16 EDT
*** Bug 107355 has been marked as a duplicate of this bug. ***
Comment 24 Harald Hoyer 2004-02-03 08:38:55 EST
*** Bug 114783 has been marked as a duplicate of this bug. ***
Comment 25 Harald Hoyer 2004-03-24 04:46:56 EST
*** Bug 118774 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.