Bug 1188147 - [RFE][Tracker] - Raise Awareness for Backups and Provide Basic Backup Tool
Summary: [RFE][Tracker] - Raise Awareness for Backups and Provide Basic Backup Tool
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Doron Fediuck
QA Contact: Gonza
URL: http://www.ovirt.org/develop/release-...
Whiteboard:
: 1058522 1169965 1176700 1176853 (view as bug list)
Depends On: 1188119 1188156 1188161
Blocks: 902971
TreeView+ depends on / blocked
 
Reported: 2015-02-02 07:38 UTC by Yaniv Lavi
Modified: 2019-09-12 08:13 UTC (History)
18 users (show)

Fixed In Version: 3.6.0-9
Doc Type: Enhancement
Doc Text:
This release adds the ability to track backups and alert the administrator if a pre-configurable time has passed since the last successful backup. There is now a clear indication when a new backup is recommended, and minimal Manager downtime in the case of corruption.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:56:12 UTC
oVirt Team: External
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Yaniv Lavi 2015-02-02 07:38:27 UTC
Feature Overview:
This feature has arose due to recent engine database corruptions where users did not have any database backup. The goal here is to cause users to do backup and review their backup options and thus reduce engine downtime on engine corruptions cases. 

Raising awareness to the necessity of backups and providing simple options using existing tools or recommending using more advanced solutions. This is the most pressing matter at hand

Scope of this Specification:
In scope:
- Ensuring users follow best practice.
- Enhancing that best practice as necessary.
- Backup of engine database remote\local.
- Backup of essential configuration files.
Out of scope:
- Creating a VM backup solution.
- automatic backup options.

User Characteristics:
- Small scale deployments that don’t have a backup solution.
- Backup of simpler usage cases.
- User that don’t have external database management.

Assumptions:
- Engine-backup already provides part of the needed functionality.
- We need to support cases where remote DB is used.
- Raising awareness of user to backups will cause increase usage of backup.

Constraints:
- Engine must not have downtime for backup if possible.
- Sufficient disk storage can be provided by user.
- DWH\Reports also need to be optionally backed up and would require more disk space. 
- I\O and network performance best practices may be limited and cause issues.
- Detailed documentation is critical to allow users to make the right choices.
- We do not want to support complex backups since it is out of the oVirt scope.

Dependencies:
In order to allow external backup for other providers, we need to provide the backup tool as the start point of backup process.

Performance:
- The backup process should not cause failures in connections to hosts or storage and should not cause failure of tasks (even if performance is affected). Stress testing should be done to define minimal requirements to backup over the network and this should be added to best practices. 
- Backup process should have a low priority in the system (low nice).
- Lower footprint should be a priority over fast completion.
- Restore time should also be a priority in default backup formats and options. 

Capacity:
- The backup should not start if disk size is not sufficient for it’s completion. 
- Two backup instances may not run at the same time.

Comment 1 Yaniv Lavi 2015-02-02 07:43:33 UTC
*** Bug 1058522 has been marked as a duplicate of this bug. ***

Comment 2 Yaniv Lavi 2015-02-02 07:43:34 UTC
*** Bug 1169965 has been marked as a duplicate of this bug. ***

Comment 3 Yaniv Lavi 2015-02-02 07:43:38 UTC
*** Bug 1176700 has been marked as a duplicate of this bug. ***

Comment 4 Yaniv Lavi 2015-02-02 07:43:39 UTC
*** Bug 1176853 has been marked as a duplicate of this bug. ***

Comment 5 Sandro Bonazzola 2015-06-04 08:18:39 UTC
Moving to infra since nothing left to do on integration side.

Comment 6 Oved Ourfali 2015-06-04 12:06:28 UTC
(In reply to Sandro Bonazzola from comment #5)
> Moving to infra since nothing left to do on integration side.

That isn't a reason to move a whiteboard.
No additional items on infra as well.
We can mark that as external or something.

Comment 7 Marina Kalinin 2015-06-08 19:39:53 UTC
What is the difference between this bug and this one: bz#1188119 ?

Comment 8 Marina Kalinin 2015-06-08 19:48:44 UTC
(In reply to Marina from comment #7)
> What is the difference between this bug and this one: bz#1188119 ?

Oh, my bad, the other one is oVirt.

Comment 14 Eyal Edri 2015-08-13 10:37:05 UTC
moving old bug fixed before ovirt alpha release as fixed in current beta2, 
3.6.0-9.

Comment 15 Gonza 2015-11-26 16:09:15 UTC
All dependencies for backup awareness have been verified.
2 docs BZs related to this tracker still open but targeted for 3.6.1 and 4.0.
Setting to verified.

Comment 21 errata-xmlrpc 2016-03-09 20:56:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.