Bug 118822 - mozilla crashes in font code
mozilla crashes in font code
Status: CLOSED DUPLICATE of bug 118587
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-20 23:44 EST by Bill Nottingham
Modified: 2014-03-16 22:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-03-20 23:44:51 EST
Generally happens when hitting the spacebar. Hence, often.

[notting@nostromo: ~]$ rpm -q mozilla xorg-x11
mozilla-1.6-2
xorg-x11-0.0.6.6-0.0.2004_03_11.6

3459  open("/usr/share/fonts/bitmap-fonts/lutRS14.pcf", O_RDONLY) = 32
3459  fcntl64(32, F_SETFD, FD_CLOEXEC)  = 0
3459  fstat64(32, {st_mode=S_IFREG|0644, st_size=80556, ...}) = 0
3459  mmap2(NULL, 80556, PROT_READ, MAP_PRIVATE, 32, 0) = 0xf4306000
3459  close(32)                         = 0
3459  munmap(0xf4306000, 80556)         = 0
3459  open("/usr/share/fonts/bitmap-fonts/lutRS14.pcf", O_RDONLY) = 32
3459  fcntl64(32, F_SETFD, FD_CLOEXEC)  = 0
3459  fstat64(32, {st_mode=S_IFREG|0644, st_size=80556, ...}) = 0
3459  mmap2(NULL, 80556, PROT_READ, MAP_PRIVATE, 32, 0) = 0xf42f2000
3459  close(32)                         = 0
3459  munmap(0xf42f2000, 80556)         = 0
3459  --- SIGSEGV (Segmentation fault) @ 0 (0) ---
Comment 1 Bill Nottingham 2004-03-21 00:05:34 EST
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -150093696 (LWP 27814)]
0x01083ce7 in TextStyle (this=0xfef1a8b0, aPresContext=0x99825a0,
    aRenderingContext=@0x98a5700, sc=0x9d66254) at nsTextFrame.cpp:548
548           mNormalFont->GetSpaceWidth(mSpaceWidth);

(gdb) bt
#0  0x01083ce7 in TextStyle (this=0xfef1a8b0, aPresContext=0x99825a0,
    aRenderingContext=@0x98a5700, sc=0x9d66254) at nsTextFrame.cpp:548
#1  0x0107b0dc in nsTextFrame::Paint(nsIPresContext*,
nsIRenderingContext&, nsRect const&, nsFramePaintLayer, unsigned)
(this=0x9d22a20,
    aPresContext=0x99825a0, aRenderingContext=@0x98a5700,
    aDirtyRect=@0xfef1a960, aWhichLayer=eFramePaintLayer_Overlay,
aFlags=0)
    at nsTextFrame.cpp:1432
#2  0x010378ab in nsContainerFrame::PaintChild(nsIPresContext*,
nsIRenderingContext&, nsRect const&, nsIFrame*, nsFramePaintLayer,
unsigned) (this=0x9d66204,
    aPresContext=0x99825a0, aRenderingContext=@0x98a5700,
    aDirtyRect=@0x424c0001, aFrame=0x9d22a20,
    aWhichLayer=eFramePaintLayer_Overlay, aFlags=0) at
nsContainerFrame.cpp:285

Warren has a full crash at http://togami.com/~warren/temp/MOZILLACRASH
Comment 2 Warren Togami 2004-03-21 01:08:03 EST
http://togami.com/~warren/archive/2004/MOZILLACRASH
Moved the mozilla and epiphany backtraces here.

Three methods to reproduce:
1) http://www.mrpalm.com/mobilephone_zone/connect.php3
2) http://www.amazon.com/gp/sign-in.html/
   Attempt to type anything in the web form
3) http://www.vmware.com/vmwarestore/newstore/download_login.jsp
   Login using your VMWare name & password.  On the next page do
   ANYTHING and it crashes.
Comment 3 Warren Togami 2004-03-21 01:11:26 EST
Note that this happened with both mozilla-1.6 and firefox-0.8 binaries
that worked fine a few days ago.  Upgrading something underneith it
introduced this crash.
Comment 4 Christopher Aillon 2004-03-21 02:14:50 EST
Right before the crash, my debug build spews:

###!!! ASSERTION: font metrics should not be null - bug 136248:
'NS_SUCCEEDED(rv)', file
/usr/local/src/mozilla/trunk/mozilla/gfx/src/nsDeviceContext.cpp, line 668
Break: at file
/usr/local/src/mozilla/trunk/mozilla/gfx/src/nsDeviceContext.cpp, line 668
###!!! ASSERTION: no font metrics: 'nsnull != aFontMetrics', file
/usr/local/src/mozilla/trunk/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 2100
Break: at file
/usr/local/src/mozilla/trunk/mozilla/layout/html/base/src/nsHTMLReflowState.cpp,
line 2100

Program received signal SIGSEGV, Segmentation fault.
Comment 5 Christopher Aillon 2004-03-21 03:18:07 EST
David Baron suggested that this may be caused by having non-existant
fonts still referenced in a fonts.cache-1 file.  That's a known
crasher on the Mozilla trunk...
Comment 6 Bill Nottingham 2004-03-22 01:21:28 EST
Nope, it happens with 1.4.2 too.

As best as I can tell, this is actually a manifestation of bug 118587.

Where it crases for me is, for example, when it starts to display text
(or a cursor) in a textbox. The font I have selected for a textbox is
LucidaSansTypewriter-10. If I change it to (for example) Vera Sans, it
no longer crashes. It appears to be getting invalid metrics back from
Xft for the bitmap font, judging from the mozilla debug errors. While
gnome-terminal (pango?) ignores the font and substitutes something
else, mozilla just blows up.

Comment 7 Bill Nottingham 2004-03-22 01:54:40 EST
Confirmed, fix for 118587 fixes this.

*** This bug has been marked as a duplicate of 118587 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.