Bug 118587 (xftbitmap) - Xft does not handle bitmap fonts correctly with freetype-2.1.7
Summary: Xft does not handle bitmap fonts correctly with freetype-2.1.7
Status: CLOSED RAWHIDE
Alias: xftbitmap
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
: 118822 118968 (view as bug list)
Depends On:
Blocks: FC2Blocker
TreeView+ depends on / blocked
 
Reported: 2004-03-17 22:47 UTC by Bill Nottingham
Modified: 2014-03-17 02:43 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-25 07:01:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LucidaTypeWriter 10 screenshot in gnome-terminal 2.5.91-1.1 (292.02 KB, image/png)
2004-03-19 05:36 UTC, sangu
no flags Details

Description Bill Nottingham 2004-03-17 22:47:10 UTC
I select 'LucidaTypewriter-10' in gnome-terminal, and I get something
that is *not* LucidaTypewriter.

Not sure what it is, but it's proportional :) , and it also looks
to be !bitmap.

Comment 1 Mike A. Harris 2004-03-18 17:18:12 UTC
gnome-terminal is using fontconfig/Xft I believe.

Owen, has fonts.conf changed recently, or have there been any other
font related changes you're aware of?

Comment 2 Mike A. Harris 2004-03-18 19:58:38 UTC
I believe I've found the cause of this problem.  It seems to be
a bug in Xft 2.1.5:

http://freedesktop.org/pipermail/xlibs/2004-March/000262.html


Comment 3 sangu 2004-03-19 05:36:38 UTC
Created attachment 98672 [details]
LucidaTypeWriter 10  screenshot in gnome-terminal 2.5.91-1.1

XFree86-4.3.0-64, fontconfig-2.2.1-8.1 freetype-2.1.7-3

Comment 4 Alexander Larsson 2004-03-19 13:06:51 UTC
Is this still happening. That sounds pretty bad?


Comment 5 Bill Nottingham 2004-03-19 16:40:00 UTC
It just started with x.org. Haven't tested today's build, will do that
at some point.

Comment 6 Bill Nottingham 2004-03-22 06:16:14 UTC
Still happens with current builds.

Comment 7 Bill Nottingham 2004-03-22 06:54:43 UTC
*** Bug 118822 has been marked as a duplicate of this bug. ***

Comment 8 Bill Nottingham 2004-03-22 07:00:07 UTC
http://pdx.freedesktop.org/cgi-bin/viewcvs.cgi/xlibs/Xft/xftfreetype.c?r1=text&tr1=1.40&r2=text&tr2=1.42&diff_format=u

fixes both gnome-terminal and mozilla for me.

Comment 9 Bill Nottingham 2004-03-23 17:35:45 UTC
*** Bug 118968 has been marked as a duplicate of this bug. ***

Comment 10 Mike A. Harris 2004-03-23 22:52:47 UTC
Assigned bug alias "xftbitmap" to this issue for easier closing
of dupes.

Comment 11 Mike A. Harris 2004-03-23 22:54:04 UTC
Fixed in 0.0.6.6-0.0.2004_03_11.8 by above patch from Xft 2.1.6.

Additional note: the latest Xorg CVS has the new Xft 2.1.6
integrated.



Comment 12 Mike A. Harris 2004-03-24 08:21:19 UTC
Fixed in rawhide, in xorg-x11-0.0.6.6-0.0.2004_03_11.8, which will
be available tomorrow sometime.

Comment 13 Christopher Aillon 2004-03-24 22:01:09 UTC
I still see a crash in Mozilla font code (see bug 118822) on
http://www.mrpalm.com/mobilephone_zone/connect.php3 after updating to
xorg-x11-0.0.6.6-0.0.2004_03_11.8.  The crash on amazon seems to be
fixed however.

Comment 14 Mike A. Harris 2004-03-24 22:07:05 UTC
Somehow the patch got inadvertently excluded from being applied.
I've fixed this and am building xorg-x11-0.0.6.6-0.0.2004_03_11.9
right now.

Comment 15 Mike A. Harris 2004-03-25 07:01:07 UTC
<caillon> mharris, sweet, .9 works nicely


Ok, closing as fixed in RAWHIDE again.


Note You need to log in before you can comment on or make changes to this bug.