Bug 118837 - /etc/ppp/connect-errors should not exist, logs belong in /var/log
/etc/ppp/connect-errors should not exist, logs belong in /var/log
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
: 119780 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-21 06:49 EST by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-07 11:46:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-03-21 06:49:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
/etc/ppp/connect-errors should not exist.  pppd should not need write access to /etc for any reason.

The SE Linux policy for pppd prevents it from writing to anything under /etc, I think that this matches the correct design for the system and that pppd should be changed to match.

Is such a log file necessary anyway?  Couldn't it just all go to syslog?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:
Comment 1 Bill Nottingham 2004-04-05 18:06:03 EDT
*** Bug 119780 has been marked as a duplicate of this bug. ***
Comment 9 Nils Philippsen 2004-05-07 11:46:26 EDT
ppp-2.4.2-5 which has these changes:

/etc/ppp/resolv.conf -> /var/run/ppp/resolv.conf
/etc/ppp/connect-errors -> /var/log/ppp/connect-errors

to avoid writing into /etc and an appropriate logrotate script should
hit Rawhide shortly.
Comment 10 Jason 2004-05-10 17:01:36 EDT
Where can I get ppp-2.4.2-5?  It is not in
http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/
Comment 11 Nils Philippsen 2004-05-10 17:07:49 EDT
Shortly, patience is the key here ;-). I'm sure it will get there with
the next push. CLOSED->RAWHIDEmeans that we have a package ready
_internally_, there is always a delay between when we are done and
when a package hits the FTP server.
Comment 12 Jason 2004-05-10 17:10:28 EDT
Thank you.  I look forward to trying the new version.
Comment 13 Matthew Miller 2004-11-06 11:39:25 EST
ppp-2.4.2-5.2.FC2 has lines in the %install section of the spec file
to create the symlinks mentioned in comment #9, but they don't
actually end up in the binary RPM.

(This also appears to be the case in ppp-2.4.2-7 in rawhide...)

Am I missing something?

Note You need to log in before you can comment on or make changes to this bug.