Bug 119780 - selinux won't let pppd connect to internet
selinux won't let pppd connect to internet
Status: CLOSED DUPLICATE of bug 118837
Product: Fedora
Classification: Fedora
Component: policy (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-01 23:07 EST by Jason
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jason 2004-04-01 23:07:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6)
Gecko/20040113

Description of problem:
I did a fresh install of FC2T2 and upgraded to the 2.6.4.1-300 kernel.
 I use an actiontec call waiting modem to dial up to the internet. 
When I type in /etc/ppp/ppp-on I get the following selinux message:


Mar 31 22:05:47 excalibur kernel: PPP generic driver version 2.4.2
Mar 31 22:05:47 excalibur pppd[2064]: pppd 2.4.1 started by root, uid 0
Mar 31 22:05:48 excalibur kernel: audit(1080792348.648:0): avc: 
denied  { write } for  pid=2065 exe=/usr/sbin/pppd name=ppp dev=sdb2
ino=32585 scontext=root:system_r:pppd_t
tcontext=system_u:object_r:etc_t tclass=dir
Mar 31 22:05:48 excalibur chat[2065]: Can't get terminal parameters:
Input/output error
Mar 31 22:05:48 excalibur pppd[2064]: Connect script failed
Mar 31 22:05:49 excalibur pppd[2064]: Exit.
Mar 31 22:06:51 excalibur pppd[2069]: pppd 2.4.1 started by root, uid 0
Mar 31 22:06:51 excalibur kernel: audit(1080792411.532:0): avc: 
denied  { write } for  pid=2068 exe=/usr/sbin/pppd path=/root/error1
dev=sdb2 ino=211031 scontext=root:system_r:pppd_t
tcontext=root:object_r:staff_home_t tclass=file
Mar 31 22:06:52 excalibur kernel: audit(1080792412.543:0): avc: 
denied  { write } for  pid=2070 exe=/usr/sbin/pppd name=ppp dev=sdb2
ino=32585 scontext=root:system_r:pppd_t
tcontext=system_u:object_r:etc_t tclass=dir
Mar 31 22:06:52 excalibur kernel: audit(1080792412.548:0): avc: 
denied  { getattr } for  pid=2070 exe=/bin/bash path=/root dev=sdb2
ino=210913 scontext=root:system_r:pppd_t
tcontext=root:object_r:staff_home_dir_t tclass=dir
Mar 31 22:06:52 excalibur chat[2070]: Can't get terminal parameters:
Input/output error
Mar 31 22:06:52 excalibur pppd[2069]: Connect script failed
Mar 31 22:06:53 excalibur pppd[2069]: Exit.


I tried a suggestion I received from the fedora-test forum and now I
get the following message:

Apr  1 21:20:01 excalibur kernel: PPP generic driver version 2.4.2
Apr  1 21:20:01 excalibur pppd[2403]: pppd 2.4.1 started by root, uid 0
Apr  1 21:20:02 excalibur kernel: audit(1080876002.324:0): avc: 
denied  { execute } for  pid=2404 exe=/bin/bash name=ppp-on-dialer
dev=sdb2 ino=32702 scontext=root:system_r:pppd_t
tcontext=root:object_r:pppd_etc_t tclass=file
Apr  1 21:20:02 excalibur pppd[2403]: Connect script failed
Apr  1 21:20:03 excalibur pppd[2403]: Exit.

I still cannot connect to the internet.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  install FC2T2
2.  setup pppd to dial the internet
3.  try /etc/ppp/ppp-on
    

Actual Results:  I got the error message

Expected Results:  I should be able to connect to the internet.

Additional info:
Comment 1 Jason 2004-04-02 18:14:44 EST
I just updated to policy-1.9.2-5.noarch.rpm and policy-sources-1.9.2-5
with the same results.
Comment 2 Bill Nottingham 2004-04-05 18:06:01 EDT

*** This bug has been marked as a duplicate of 118837 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:02:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.