Bug 118845 - No mouse detected after Kernel upgrade
No mouse detected after Kernel upgrade
Status: CLOSED DUPLICATE of bug 116118
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-21 10:15 EST by Chris Bosshard
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Bosshard 2004-03-21 10:15:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
After upgrading the Kernel from the initial released version
2.6.1-1.65 to 2.6.3-2.1.253.2.1 the mouse does no longer work.
As a result the X-server cannot be started.

The log shows the following:
Mar 21 14:50:21 localhost kernel: mice: PS/2 mouse device common for
all mice
Mar 21 14:50:21 localhost kernel: serio: i8042 AUX port at 0x60,0x64
irq 12
Mar 21 14:50:21 localhost kernel: input: ImExPS/2 Generic Explorer
Mouse on isa0060/serio1

and later:
Mar 21 14:50:30 localhost gpm[1548]: O0o.oops(): [gpm.c(937)]: 
Mar 21 14:50:30 localhost gpm[1548]: Could not open /dev/mouse.
Mar 21 14:50:30 localhost gpm: O0o.oops(): [gpm.c(937)]: 
Mar 21 14:50:30 localhost gpm: Starten von gpm succeeded

Hardware information:
Logitech cordless mouse connected via a four way KMD switch to the PS2
board of the mainboard with KT266 chipset. Note even if the mouse is
connected directly to the PS2 connector it does not work.

Solution:
Booting the old kernel solves the problem.

Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253.2.1

How reproducible:
Always

Steps to Reproduce:
1. Boot the machine with kernel 2.6.3-2.1.253.2.1
2.
3.
    

Actual Results:  No mouse detected by GPM, X-server cannot start

Expected Results:  Mouse detected and start of X-server without errors.

Additional info:
Comment 1 Dave Jones 2004-03-21 11:55:37 EST

*** This bug has been marked as a duplicate of 116118 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.