Bug 1189530 - java-1.8.0-openjdk provides is missing java
Summary: java-1.8.0-openjdk provides is missing java
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.8.0-openjdk   
(Show other bugs)
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukas Zachar
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks: 900676 1200567
TreeView+ depends on / blocked
 
Reported: 2015-02-05 13:53 UTC by Katerina Odabasi
Modified: 2015-11-19 03:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
With Red Hat Enterprise Linux 7.1, the java-1.8.0-openjdk packages do not provide "java" in the RPM metadata, which breaks compatibility with packages that require Java and are available from the Enterprise Application Platform (EAP) channel. To work around this problem, install another package that provides "java" in the RPM metadata before installing java-1.8.0-openjdk.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:50:32 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2181 normal SHIPPED_LIVE java-1.8.0-openjdk enhancement update 2015-11-19 07:51:57 UTC
Red Hat Bugzilla 900676 None None None Never

Internal Trackers: 900676

Description Katerina Odabasi 2015-02-05 13:53:32 UTC
Description of problem:
With RHEL7.1 java-1.8.0-openjdk package doesn't contain in provides "java" (it contains only "java-1.8.0-openjdk".
This breaks compatibility with packages from EAP channel which requires "java".

Version-Release number of selected component (if applicable):
java-1.8.0-openjdk-1.8.0.31-2.b13.el7

How reproducible:
always

Actual results:
repoquery --provides --plugins java-1.8.0-openjdk
java-1.8.0-openjdk = 1:1.8.0.31-2.b13.el7
java-1.8.0-openjdk(x86-64) = 1:1.8.0.31-2.b13.el7
...

Expected results:
The package also provides "java"

Comment 1 jiri vanek 2015-02-05 13:58:16 UTC
This is not a bug, it is a feature. Please see:

https://bugzilla.redhat.com/show_bug.cgi?id=1155783 (yes it is for rhel 6 but it is same issue)
and
https://bugzilla.redhat.com/show_bug.cgi?id=1155786

If you are more interested in this topic, search how it was during addition of openjdk7  into rhel6/

Comment 2 Katerina Odabasi 2015-02-05 14:45:36 UTC
EAP supports multiple java versions. EAP packages then cannot require specific java version, but must use generic "java".

For example java-1.7.0-openjdk on RHEL7.1 has:
# repoquery --provides --plugins java-1.7.0-openjdk
java = 1:1.7.0
java-1.7.0 = 1:1.7.0.75-2.5.4.2.el7_0
java-1.7.0-openjdk = 1:1.7.0.75-2.5.4.2.el7_0
java-1.7.0-openjdk(x86-64) = 1:1.7.0.75-2.5.4.2.el7_0
java-fonts = 1:1.7.0.75
java-openjdk = 1:1.7.0.75-2.5.4.2.el7_0
...

There are more examples like java-1.6.0-openjdk on RHEL5.

Comment 4 jiri vanek 2015-02-05 15:05:18 UTC
Please find already existing bug for this topic. I again repeat to you, this is intentional.

Comment 5 jiri vanek 2015-02-05 15:11:34 UTC
Ok. Sorry. Returning of java provides is opened only for rhel 6. And In some future should be done aslo for 7.

Comment 14 jiri vanek 2015-07-21 14:16:19 UTC
The provides are there for some time:
http://pkgs.devel.redhat.com/cgit/rpms/java-1.8.0-openjdk/tree/java-1.8.0-openjdk.spec?h=rhel-7.2

Comment 18 errata-xmlrpc 2015-11-19 03:50:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2181.html


Note You need to log in before you can comment on or make changes to this bug.