Bug 1155783 - Remove java-devel provides from java-1.8.0-openjdk [RHEL-6.7]
Summary: Remove java-devel provides from java-1.8.0-openjdk [RHEL-6.7]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.8.0-openjdk
Version: 6.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: jiri vanek
QA Contact: Lukas Zachar
URL:
Whiteboard:
Depends On:
Blocks: 1155786 1156375
TreeView+ depends on / blocked
 
Reported: 2014-10-22 19:43 UTC by Deepak Bhole
Modified: 2015-07-22 07:44 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Prior to this update, the java-1.8.0-openjdk packages incorrectly provided "java-devel", which could lead to their inclusion in inappropriate builds. As a consequence, the "yum install java-devel" command in some cases installed java-1.8.0-openjdk-devel instead of the intended Java package. This update removes the providing configuration, and java-1.8.0-openjdk-devel can now be installed only by using the "yum install java-1.8.0-openjdk-devel" command.
Clone Of:
: 1155786 1156375 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:44:34 UTC


Attachments (Terms of Use)
list of packages built after openjdk8 appeared in brew buildroot for 6.6 (13.48 KB, text/plain)
2014-10-23 14:52 UTC, jiri vanek
no flags Details
sucessfull verification that no built (except openjdk8) was build by openjdk8 for 6.6 (686.11 KB, text/plain)
2014-10-23 14:53 UTC, jiri vanek
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1427 normal SHIPPED_LIVE java-1.8.0-openjdk bug fix and enhancement update 2015-07-20 18:06:16 UTC

Description Deepak Bhole 2014-10-22 19:43:50 UTC
The current OpenJDK8 RPMs in RHEL provide java* instead of java8*. This is causing them to get pulled into brew builds when they shouldn't be.

We should fix the packages asap to make them provide java8* much like OpenJDK7 RPMs provide java7*.

Comment 1 Deepak Bhole 2014-10-22 20:03:42 UTC
On second thought, rather than replacing with java8*, we should just remove them altogether to prevent customers from depending on the provides that may end up getting removed in the future. Thanks to Omair for pointing this out.

Comment 2 jiri vanek 2014-10-23 08:12:00 UTC
Hi!

The packages are not providing java8 but have epoch set to 0. Actually the change from provides javaX to whatever was requested, so we (me, Omair and Lukas) have come out with epoch 0. This change was heavily tested and behaved correctly.

The brew-root is *not* (as far as I'm aware, and I tried a lot) pulling jdk8 unless java-1.8.0-openjdk*  or java >= 1.8.0  is explicitly requested.

If you have found some case when openjdk8 was pulled instead of 6 or  7, then it would really mean devel x qa failure and I'm terribly sorry for that and will fix immediately. Otherwise this should be closed->not a bug

Comment 3 jiri vanek 2014-10-23 08:15:36 UTC
> 
> We should fix the packages asap to make them provide java8* much like
> OpenJDK7 RPMs provide java7*.

This java7* was causing a lot of problems, and once we swithced to java = 1.7.0... there was couple of bugs requesting it back. At the end we ended up with dual provides java7* and  java* = 1.7.0...

For 8 better solution was about to be found. And this was an epoch.

Comment 4 jiri vanek 2014-10-23 11:02:36 UTC
for record:
https://bugzilla.redhat.com/show_bug.cgi?id=1149605#c15

Comment 5 jiri vanek 2014-10-23 13:17:36 UTC
Omair had, as always, very refreshing idea - to remove jpackages provides at all. This approach ahve +1 from me muh more likely then provides java8

Comment 6 Deepak Bhole 2014-10-23 13:21:39 UTC
+1 from me as well, already noted in comment #1 :)

Comment 7 jiri vanek 2014-10-23 14:52:18 UTC
Created attachment 949960 [details]
list of packages built after openjdk8 appeared in brew buildroot for 6.6

Comment 8 jiri vanek 2014-10-23 14:53:23 UTC
Created attachment 949961 [details]
sucessfull verification that no built (except openjdk8) was build by openjdk8 for 6.6

Comment 9 Devan Goodwin 2014-10-23 18:46:19 UTC
Our candlepin buildroot inherits from RHEL 6.6.Z. Here is a scratch build where we require java-devel >= 1.6.0, and openjdk 1.8 is pulled in:

http://download.devel.redhat.com/brewroot/work/tasks/5970/8155970/root.log

Jiri could you advise if you can spot what we might be doing incorrectly?

Comment 12 jiri vanek 2014-10-24 10:06:56 UTC
pushed and building

Comment 22 Lukas Zachar 2015-04-29 09:55:06 UTC
Changing bug description as bug 1189853 requested to have "java" provides in java-1.8.0-openjdk.

Only java-devel is excluded intentionally, so it does not pollute mock build root.

Comment 24 errata-xmlrpc 2015-07-22 07:44:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1427.html


Note You need to log in before you can comment on or make changes to this bug.