Bug 1189551 - [RFE][nova]: Libvirt real time instances
Summary: [RFE][nova]: Libvirt real time instances
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Sahid Ferdjaoui
QA Contact: Prasanth Anbalagan
URL: https://blueprints.launchpad.net/nova...
Whiteboard: upstream_milestone_mitaka-3 upstream_...
: 1273876 (view as bug list)
Depends On:
Blocks: 1272556 1278174
TreeView+ depends on / blocked
 
Reported: 2015-02-05 13:59 UTC by RHOS Integration
Modified: 2019-09-09 13:59 UTC (History)
16 users (show)

Fixed In Version: openstack-nova-14.0.0-0.20160822060606.aabf94f.el7ost
Doc Type: Enhancement
Doc Text:
This update adds the `real time` feature, which provides stronger guarantees for worst-case scheduler latency for vCPUs. This update assists tenants that need to run workloads concerned with CPU execution latency, and that require the guarantees offered by a real time KVM guest configuration.
Clone Of:
: 1278174 (view as bug list)
Environment:
Last Closed: 2016-12-14 15:26:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2948 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 enhancement update 2016-12-14 19:55:27 UTC

Description RHOS Integration 2015-02-05 13:59:40 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/libvirt-real-time.

Description:

The CPU pinning feature added to the ability to assigned guest
virtual CPUs to dedicated host CPUs, providing guarantees for
CPU time and improved worst case latency for CPU scheduling.
The real time feature builds on that work to provide stronger
guarantees for worst case schedular latency for vCPUs.


Specification URL (additional information):

None

Comment 4 Stephen Gordon 2015-11-04 20:38:29 UTC
*** Bug 1273876 has been marked as a duplicate of this bug. ***

Comment 5 Mike McCune 2016-03-28 23:33:48 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 9 Prasanth Anbalagan 2016-10-14 14:38:09 UTC
Verified on

openstack-nova-api.noarch             1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-cert.noarch            1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-common.noarch          1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-compute.noarch         1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-conductor.noarch       1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-console.noarch         1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-novncproxy.noarch      1:14.0.0-0.20160929203854.59653c6.el7ost
openstack-nova-scheduler.noarch       1:14.0.0-0.20160929203854.59653c6.el7ost

Logs
=====

Please check "attachment 1210569 [details]" for details.

Comment 10 Prasanth Anbalagan 2016-10-17 12:18:52 UTC
Updating information about the automation used - https://review.gerrithub.io/#/c/298301/1/rhostest_tempest_plugin/tests/scenario/test_libvirt_realtime_instance.py

Comment 12 errata-xmlrpc 2016-12-14 15:26:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2948.html


Note You need to log in before you can comment on or make changes to this bug.