Bug 119011 - [firewire] kernel oops/panic when kudzu started
[firewire] kernel oops/panic when kudzu started
Status: CLOSED DUPLICATE of bug 118546
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-23 16:09 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pciture of monitor screen when kernel oops/hangs (537.07 KB, image/jpeg)
2004-03-23 16:11 EST, Gene Czarcinski
no flags Details
dmesg with kernel 2.6.4-1.286 (11.27 KB, text/plain)
2004-03-23 16:42 EST, Gene Czarcinski
no flags Details

  None (edit)
Description Gene Czarcinski 2004-03-23 16:09:42 EST
Description of problem:
I get the a kernel oops/panic when the system is started when kudzu is
started.  The system boots up OK if kudzu is NOT started.  A picture
of the monitor screen is attached which shows the output.

 The system is an Opteron 140 on an ASUS SK8V motherboard.

The system was booted without the GUI boot and with selinux=0

The firewire stuff was renamed so it could not be loaded.



Version-Release number of selected component (if applicable):
March 22 snapshot of development was used.  This includes
kernel-2.6.3-2.1.253.2.1.i686.rpm 

How reproducible:
every time if kudzu is started.


-----------------------------------------------------------
lcpci -n:
00:00.0 Class 0600: 1106:3188 (rev 01)
00:01.0 Class 0604: 1106:b188
00:07.0 Class 0c00: 1106:3044 (rev 80)
00:0a.0 Class 0200: 10b7:1700 (rev 12)
00:0f.0 Class 0104: 1106:3149 (rev 80)
00:0f.1 Class 0101: 1106:0571 (rev 06)
00:10.0 Class 0c03: 1106:3038 (rev 81)
00:10.1 Class 0c03: 1106:3038 (rev 81)
00:10.2 Class 0c03: 1106:3038 (rev 81)
00:10.3 Class 0c03: 1106:3038 (rev 81)
00:10.4 Class 0c03: 1106:3104 (rev 86)
00:11.0 Class 0601: 1106:3227
00:11.5 Class 0401: 1106:3059 (rev 60)
00:18.0 Class 0600: 1022:1100
00:18.1 Class 0600: 1022:1101
00:18.2 Class 0600: 1022:1102
00:18.3 Class 0600: 1022:1103
01:00.0 Class 0300: 1002:514d (rev 80)

lspci -v:
00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host
Bridge (rev 01)
        Subsystem: Asustek Computer, Inc.: Unknown device 80a3
        Flags: bus master, 66Mhz, medium devsel, latency 8
        Memory at f8000000 (32-bit, prefetchable)
        Capabilities: [80] AGP version 3.5
        Capabilities: [c0] #08 [0060]
        Capabilities: [68] Power Management version 2
        Capabilities: [58] #08 [8001]
 
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800
South] (prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
        I/O behind bridge: 0000a000-0000afff
        Memory behind bridge: fd500000-fd8fffff
        Prefetchable memory behind bridge: d7f00000-f7efffff
        Expansion ROM at 0000a000 [disabled] [size=4K]
        Capabilities: [80] Power Management version 2
 
00:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host
Controller (rev 80) (prog-if 10 [OHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 808a
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at fd900000 (32-bit, non-prefetchable)
        I/O ports at ec00 [size=128]
        Capabilities: [50] Power Management version 2
 
00:0a.0 Ethernet controller: 3Com Corporation 3c940 1000Base? (rev 12)
        Subsystem: Asustek Computer, Inc.: Unknown device 80eb
        Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 10
        Memory at fdc00000 (32-bit, non-prefetchable)
        I/O ports at b000 [size=256]
        Capabilities: [48] Power Management version 2
        Capabilities: [50] Vital Product Data
 
00:0f.0 RAID bus controller: VIA Technologies, Inc.: Unknown device
3149 (rev 80)
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at e800
        I/O ports at e400 [size=4]
        I/O ports at e000 [size=8]
        I/O ports at d800 [size=4]
        I/O ports at d400 [size=16]
        I/O ports at d000 [size=256]
        Capabilities: [c0] Power Management version 2
 
00:0f.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev
06) (prog-if 8a [Master SecP PriP])
        Subsystem: VIA Technologies, Inc.
VT82C586/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE
        Flags: bus master, medium devsel, latency 32, IRQ 11
        I/O ports at fc00 [size=16]
        Capabilities: [c0] Power Management version 2
 
00:10.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at b400 [size=32]
        Capabilities: [80] Power Management version 2
 
00:10.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at b800 [size=32]
        Capabilities: [80] Power Management version 2
 
00:10.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at c000 [size=32]
        Capabilities: [80] Power Management version 2
 
00:10.3 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 81) (prog-if 00 [UHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 10
        I/O ports at c400 [size=32]
        Capabilities: [80] Power Management version 2
 
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
(prog-if 20 [EHCI])
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, medium devsel, latency 64, IRQ 5
        Memory at fdf00000 (32-bit, non-prefetchable)
        Capabilities: [80] Power Management version 2
 
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800
South]
        Subsystem: Asustek Computer, Inc.: Unknown device 80ed
        Flags: bus master, stepping, medium devsel, latency 0
        Capabilities: [c0] Power Management version 2
 
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
        Subsystem: Asustek Computer, Inc.: Unknown device 80f3
        Flags: medium devsel, IRQ 5
        I/O ports at c800
        Capabilities: [c0] Power Management version 2
 
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
        Flags: fast devsel
        Capabilities: [80] #08 [2101]
        Capabilities: [a0] #08 [2101]
        Capabilities: [c0] #08 [2101]
 
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
        Flags: fast devsel
 
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
        Flags: fast devsel
 
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
        Flags: fast devsel
 
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QM
[Radeon 9100] (rev 80) (prog-if 00 [VGA])
        Subsystem: PC Partner Limited: Unknown device 7149
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64,
IRQ 11
        Memory at e0000000 (32-bit, prefetchable) [size=fd700000]
        I/O ports at a000 [size=256]
        Memory at fd800000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at 00020000 [disabled]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
Comment 1 Gene Czarcinski 2004-03-23 16:11:31 EST
Created attachment 98801 [details]
pciture of monitor screen when kernel oops/hangs
Comment 2 Gene Czarcinski 2004-03-23 16:15:28 EST
This occurs with the firewire (1394) modules available (loaded) and
without them.  I saw the other reports and this did not look like them
... that is why the separate report.
Comment 3 Gene Czarcinski 2004-03-23 16:41:27 EST
I tried kernel-2.6.4-1.286.i686.rpm from people.redhat.com/arjanv

It does not work either ... but differently does not work.

1. No hang ... but still got the messages in picture.

2. With kudzu, the sk98lin NIC does not initialize ("no present") ...
without kudzu, works fine.

attached is dmesg
Comment 4 Gene Czarcinski 2004-03-23 16:42:35 EST
Created attachment 98808 [details]
dmesg with kernel 2.6.4-1.286
Comment 5 Sahil Verma 2004-03-23 17:33:03 EST
Similar backtrace in <a
href="https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=118546">118456</a>,
except that's on module unload.
Comment 6 Gene Czarcinski 2004-03-24 17:49:44 EST
This is also occuring on FC2 x86_64 development (not surprised).

Also found out that when it occurs, the system is not really hung in
that will do a ctl-alt-del to force a shutdown and reboot.
Comment 7 Gene Czarcinski 2004-03-30 07:27:38 EST
This looks pretty much the same as 118546 so I am close this as dup.

*** This bug has been marked as a duplicate of 118546 ***
Comment 8 Red Hat Bugzilla 2006-02-21 14:02:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.