Bug 118546 - Removal of sk98lin.ko-module crashes
Removal of sk98lin.ko-module crashes
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 119011 119672 (view as bug list)
Depends On:
Blocks: FC2Blocker
  Show dependency treegraph
 
Reported: 2004-03-17 11:51 EST by Timo Kujala
Modified: 2013-07-02 22:18 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-16 04:53:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Timo Kujala 2004-03-17 11:51:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040312

Description of problem:
Removal of sk98lin.o-module causes kernel to oops.
This is bad, as kudzu does this during startup and system won't boot.

This is what I was able to save:
----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at generic:664
invalid operand: 0000 [1]
CPU 0
Pid: 1255, comm: modprobe Not tainted
RIP: 0010:[<ffffffff801cc059>] <ffffffff801cc059>{remove_proc_entry+197}
RSP: 0018:000001003e72fec8  EFLAGS: 00010206
RAX: 0000000000000001 RBX: 000001003e6491a0 RCX: 0000000000000000
RDX: 000001003e6491a0 RSI: 000001003e64922f RDI: 000001003e6491a0
RBP: 00000100024509a8 R08: 0000000000000000 R09: 000001003e590000
R10: 0000000000000000 R11: 0000000000000000 R12: 000001003e649228
R13: 0000000000000007 R14: 000000000040e9e0 R15: 0000000000538848
FS:  0000002a958624c0(0000) GS:ffffffff804ab600(0000)
knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000002a956e53d0 CR3: 0000000000101000 CR4: 00000000000006e0
Process modprobe (pid: 1255, stackpage=1000258fda0)
Stack: 0000000000538848 0000010002450948 000001003e649228 ffffffffa00fb680
       0000000000000000 ffffffff803e82c0 0000000000000080 ffffffff801551b3
       0000000000000001 0000000037f485e0
Call Trace:<ffffffff801551b3>{sys_delete_module+281}
<ffffffff80176549>{do_munmap+639}
       <ffffffff8017659b>{sys_munmap+69}
<ffffffff80111ef6>{system_call+126}
        
 
Code: 0f 0b 73 b5 32 80 ff ff ff ff 98 02 8b 83 80 00 00 00 85 c0
RIP <ffffffff801cc059>{remove_proc_entry+197} RSP <000001003e72fec8>
  
Currently only way around this (what I have found) is to delete the
sk98lin.ko and play with the 100Mb NIC.


Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253, kernel-2.6.3-2.1.253.2.1

How reproducible:
Always

Steps to Reproduce:
1.Boot to single-user
2.modprobe sk98lin
3.modprobe -r sk98lin
    
(probably you'll need a system with 1Gb NIC to reproduce this)


Actual Results:  Kernel oops, and can't touch any modules after that
point.

Expected Results:  Shouldn't crash

Additional info:

Seen same thing earlier with snd-via82xx, but it has disappeared.
Comment 1 Timo Kujala 2004-03-17 13:32:48 EST
Same thing with 2.6.4-1.275:

----------- [cut here ] --------- [please bite here ] ---------
Kernel BUG at generic:664
invalid operand: 0000 [1]
CPU 0
Pid: 1229, comm: modprobe Not tainted
RIP: 0010:[<ffffffff801cc396>] <ffffffff801cc396>{remove_proc_entry+197}
RSP: 0018:000001003f70bec8  EFLAGS: 00010206
RAX: 0000000000000001 RBX: 000001003e923b78 RCX: 0000000000000000
RDX: 000001003e923b78 RSI: 000001003e923c07 RDI: 000001003e923b78
RBP: 00000100024529a8 R08: 0000000000000000 R09: 000001003ea00000
R10: 0000000000000000 R11: 0000000000000000 R12: 000001003e923c00
R13: 0000000000000007 R14: 000000000040e9e0 R15: 0000000000538838
FS:  0000002a958624c0(0000) GS:ffffffff804c0d80(0000)
knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: 0000002a95a62cc8 CR3: 0000000000101000 CR4: 00000000000006e0
Process modprobe (pid: 1229, stackpage=1003efa9300)
Stack: 0000000000538838 0000010002452948 000001003e923c00 ffffffffa00e3580
       ffffffff803f9e60 0000000000000000 0000000000000080 ffffffff801553ad
       0000000000000001 000000003ff9e088
Call Trace:<ffffffff801553ad>{sys_delete_module+303}
<ffffffff80176902>{do_munmap+639}
       <ffffffff80176954>{sys_munmap+69}
<ffffffff80111eea>{system_call+126}
        
 
Code: 0f 0b bb 7c 33 80 ff ff ff ff 98 02 8b 83 80 00 00 00 85 c0
RIP <ffffffff801cc396>{remove_proc_entry+197} RSP <000001003f70bec8>
  

Comment 2 Karen Spearel 2004-03-30 04:59:06 EST
this same bug kills both the i386 and x86_64 versions of FC2 T2 (fresh
install using the stock kernel) on my Asus K8V which has a 3c940
network interface and therefore uses the sk98lin driver.  
Comment 3 Gene Czarcinski 2004-03-30 07:22:04 EST
Yes, it is still there with FC2-Test2.  The only way I have found to
proceed is to disable starting kudzu.
Comment 4 Gene Czarcinski 2004-03-30 07:27:41 EST
*** Bug 119011 has been marked as a duplicate of this bug. ***
Comment 5 Jirka Jurek 2004-04-02 01:27:39 EST
*** Bug 119672 has been marked as a duplicate of this bug. ***
Comment 6 Albert Strasheim 2004-04-03 03:28:49 EST
Same problem with my 3C940 on my Asus P4C800 Deluxe motherboard.

I think the oops reads:

kernel BUG at fs/proc/generic.c:664

The problem exists when booting with SMP and UP.
Comment 7 Roman Zielinski 2004-04-03 16:05:15 EST
Same problem wit Asus A7V600 AMD XP3000+ (3c2000 on the mobo).

To avoid the crash at bootup (kudzu) I introduced
/etc/rc.modules with content:
modprobe sk98lin
Comment 8 Miguel Dardenne 2004-04-08 09:47:28 EDT
Same problem with my 3C940 on my Asus P4C800 Deluxe motherboard.

kernel BUG at fs/proc/generic.c:664!
invalid operand: 0000 [#1]
SMP
CPU:    0
EIP:    0060:[<02193fa4>] Not tainted
EFLAGS: 00010206 (2.6.3-2.1.253.2.1smp)
EIP is at remove_proc_entry+0xa6/0xf6
eax: 21feacb0  ebx: 0dc56494  ecx: 00000000  edx: 21f2acb0
esi: 21feacb0  edi: 0dc5644c  ebp: 00000007  esp: 0a92bf30
ds: 007b  es: 007b  ss: 0068
Process modprobe (pid: 1603, threadinfo=0a92b000 task=1f3a0ce0)
Stack: 
21f2ac80 0dc56494 07f00000 00000000 022f6b38 0a92b000 22a6e743 22a76f00
00000000 0213f9ee 0213bd36 22a76f00 00000000 022f6b38 0a92b000 0213bebb
00000000 38396b73 006e696c 21eb5318 f704d000 02155129 1d2f6870 f704e000

Call Trace:
[<22a6e743>] skge_cleanup_module+0x1b3/0x1bb [sk98lin]
[<0213f9ee>] stop_machine_run+0x13/0x18
[<0213bd36>] try_stop_module+0x1f/0x23
[<0213bebb>] sys_delete_module+0x1f/0x23
[<02155129>] unmap_vma_list+0xe/0x17
[<021555d7>] do_munmap+0x17c/0x18a

Code: 0f 0b 98 02 91 50 2c 02 8b 47 40 85 c0 75 09 89 f8 e8 0c ff
Comment 9 Gene Czarcinski 2004-04-11 16:53:30 EDT
still there with kudzu = 1.1.54-1, kernel = 2.6.5-1.315 on ASUS SK8V
with Opteron 140.
Comment 10 Gene Czarcinski 2004-04-14 13:47:03 EDT
After installing kernel-2.6.5-1.322, I can run kudzu and the NIC works
too.  This problem appears to be fixed.  Suggest this be closed as
fixed in rawhide.  [mobo: ASUS SK8V with Opteron 140]
Comment 11 Karen Spearel 2004-04-14 16:16:13 EDT
the kernel oops is gone on my Asus K8V/3200+ also.  However, upon
removing the 8139 NIC I was using and removing the only hardware
listed in system-config-network, kudzu didn't find my 3c940 upon
reboot (it did on original install).  Adding "alias eth0 sk98lin" in
modprobe.conf and manually modprobing sk98lin did allow me to use
system-config-network gui (or whatever its called) to  reinstall/
activate.  Checking things upon a reboot, the original problem is
gone...so I agree that this one can be closed. 
Comment 12 Arjan van de Ven 2004-04-16 04:53:22 EDT
ok closing then .. thanks for testing

Note You need to log in before you can comment on or make changes to this bug.