Bug 1190458 - [abrt] dnf: cli.py:210:do_transaction:UnicodeEncodeError: 'ascii' codec can't encode character u'\xf3' in position 196: ordinal not in range(128)
Summary: [abrt] dnf: cli.py:210:do_transaction:UnicodeEncodeError: 'ascii' codec can't...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 21
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Honza Silhan
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:394752760e2772e7053d87fcacc...
Keywords:
: 1194969 1198749 1199739 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-08 06:42 UTC by Angelus
Modified: 2015-05-08 07:33 UTC (History)
11 users (show)

Fixed In Version: dnf-plugins-core-0.1.5-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-06 18:49:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (5.48 KB, text/plain)
2015-02-08 06:42 UTC, Angelus
no flags Details
File: environ (2.61 KB, text/plain)
2015-02-08 06:42 UTC, Angelus
no flags Details

Description Angelus 2015-02-08 06:42:47 UTC
Version-Release number of selected component:
dnf-0.6.3-2.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python -OO /bin/dnf -y upgrade
executable:     /bin/dnf
kernel:         3.18.3-201.fc21.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 do_transaction in /usr/lib/python2.7/site-packages/dnf/cli/cli.py:210
#2 resolving in /usr/lib/python2.7/site-packages/dnf/cli/main.py:160
#3 _main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:141
#4 main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:84
#5 user_main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:182
#6 <module> in /bin/dnf:36

Comment 1 Angelus 2015-02-08 06:42:50 UTC
Created attachment 989323 [details]
File: backtrace

Comment 2 Angelus 2015-02-08 06:42:58 UTC
Created attachment 989324 [details]
File: environ

Comment 3 Honza Silhan 2015-03-03 16:15:50 UTC
Thanks for the report. Fixed in the upstream.

Comment 4 Honza Silhan 2015-03-12 12:20:37 UTC
*** Bug 1194969 has been marked as a duplicate of this bug. ***

Comment 5 Honza Silhan 2015-03-17 10:07:38 UTC
*** Bug 1198749 has been marked as a duplicate of this bug. ***

Comment 6 Honza Silhan 2015-03-24 13:47:17 UTC
*** Bug 1199739 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2015-03-31 18:18:03 UTC
hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 8 Fedora Update System 2015-04-02 01:44:18 UTC
Package hawkey-0.5.4-1.fc22, dnf-0.6.5-1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing hawkey-0.5.4-1.fc22 dnf-0.6.5-1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-5337/hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2015-04-03 11:39:35 UTC
dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnf-plugins-extras-0.0.6-2.fc22,yum-utils-1.1.31-505.fc22,yum-3.4.3-505.fc22,hawkey-0.5.4-1.fc22,dnf-0.6.5-1.fc22

Comment 10 Fedora Update System 2015-04-06 18:49:27 UTC
dnf-plugins-extras-0.0.6-2.fc22, yum-3.4.3-505.fc22, dnf-0.6.5-1.fc22, yum-utils-1.1.31-505.fc22, hawkey-0.5.4-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2015-04-16 09:05:02 UTC
dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.5-2.fc21,dnf-0.6.4-5.fc21

Comment 12 Fedora Update System 2015-05-08 07:33:01 UTC
dnf-plugins-core-0.1.5-2.fc21, dnf-0.6.4-5.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.