Bug 1198749 - [abrt] dnf: cli.py:210:do_transaction:UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 259: ordinal not in range(128)
[abrt] dnf: cli.py:210:do_transaction:UnicodeEncodeError: 'ascii' codec can't...
Status: CLOSED DUPLICATE of bug 1190458
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:3ca89e6c47ca279a175b91f54f0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-03-04 13:23 EST by Thomas Spura
Modified: 2015-04-05 07:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-17 06:07:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (8.64 KB, text/plain)
2015-03-04 13:23 EST, Thomas Spura
no flags Details
File: environ (2.65 KB, text/plain)
2015-03-04 13:23 EST, Thomas Spura
no flags Details

  None (edit)
Description Thomas Spura 2015-03-04 13:23:30 EST
Description of problem:
Installing a package, where "the communication was resetted", but in German locale. The console output seems to let dnf crash as a result of ü.

Here is the console output:
[MIRROR] gettext-common-devel-0.19.4-4.fc22.noarch.rpm: Curl error (56): Failure when receiving data from the peer for http://ftp.tu-chemnitz.de/pub/linux/fedora/linux/development/22/x86_64/os/Packages/g/gettext-common-devel-0.19.4-4.fc22.noarch.rpm [Recv failure: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt]
[FAILED] gettext-common-devel-0.19.4-4.fc22.noarch.rpm: Curl error (56): Failure when receiving data from the peer for http://ftp.tu-chemnitz.de/pub/linux/fedora/linux/development/22/x86_64/os/Packages/g/gettext-common-devel-0.19.4-4.fc22.noarch.rpm [Recv failure: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt]
Traceback (most recent call last):.1-3.fc21.noarch.rpm  32% [=================                                     ] 482 kB/s | 3.4 MB     00:15 ETA
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 182, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 160, in resolving
    base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 210, in do_transaction
    specific = dnf.cli.format.indent_block(str(e))
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 259: ordinal not in range(128)

Version-Release number of selected component:
dnf-0.6.4-2.fc22

Additional info:
reporter:       libreport-2.4.0
cmdline:        /usr/bin/python -OO /bin/dnf install a52dec-devel gettext-devel gstreamer-plugins-base-devel gtk-doc libdvdread-devel libid3tag-devel libmad-devel mpeg2dec-devel opencore-amr-devel twolame-devel
dso_list:       python-dnf-0.6.4-2.fc22.noarch
executable:     /bin/dnf
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
#1 do_transaction in /usr/lib/python2.7/site-packages/dnf/cli/cli.py:210
#2 resolving in /usr/lib/python2.7/site-packages/dnf/cli/main.py:160
#3 _main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:141
#4 main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:84
#5 user_main in /usr/lib/python2.7/site-packages/dnf/cli/main.py:182
#6 <module> in /bin/dnf:36
Comment 1 Thomas Spura 2015-03-04 13:23:34 EST
Created attachment 997996 [details]
File: backtrace
Comment 2 Thomas Spura 2015-03-04 13:23:35 EST
Created attachment 997997 [details]
File: environ
Comment 3 Honza Silhan 2015-03-17 06:07:38 EDT

*** This bug has been marked as a duplicate of bug 1190458 ***

Note You need to log in before you can comment on or make changes to this bug.