Bug 119075 - /dev/usb/lp entry changes when re-powering printer back on
/dev/usb/lp entry changes when re-powering printer back on
Status: CLOSED DUPLICATE of bug 81164
Product: Fedora
Classification: Fedora
Component: hpijs (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-24 13:23 EST by Youssef Makki
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 09:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Youssef Makki 2004-03-24 13:23:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040211 Firefox/0.8

Description of problem:
When the printer is powered off and back on, it is assigned a
different /dev/usb/lp entry. For example it starts with lp0 when I
boot the machine, and goes to lp1 when I power cycle the printer. It
seems to be confined to alternating between lp0 and lp1 only. Another
important note, this seems to only happen when there are documents in
queue waiting to be printed. The printer behaves normally if I simply
power-cycle it (according to the few times I've tested).
After switching the printer back on, redhat-config-printer-gui
displays "Unable to open USB device "usb:/dev/usb/lp0": No such
device" under Description. Pressing 'Edit' and going to 'Queue type',
the printer's previous device entry now displays '/dev/usb/lp0  
Custom Device', and the printer itself is /dev/usb/lp1. You have to
Rescan Devices, and then Apply the settings for everything to work.
This can be reproduced by switching the printer back off/on, this time
the printer would be back to lp0.


Version-Release number of selected component (if applicable):
hpijs-1.5-4.2

How reproducible:
Always

Steps to Reproduce:
1. Power printer off
2. Print a document
3. Power printer on
    

Actual Results:  The printer was assigned a different /dev/usb/lpX entry

Expected Results:  The /dev/usb/lpX entry should not change

Additional info:

The printer is an HP DeskJet 656C

Some output from /var/log/messages which seems to be repeated when
reproducing this problem:

Mar 24 13:26:18 galileo devlabel: devlabel service started/restarted
Mar 24 13:27:34 galileo kernel: usb.c: USB disconnect on device
00:1f.4-2 address 9
Mar 24 13:27:34 galileo kernel: printer.c: usblp0: removed
Mar 24 13:27:37 galileo devlabel: devlabel service started/restarted
Mar 24 13:28:44 galileo kernel: hub.c: new USB device 00:1f.4-2,
assigned address 10
Mar 24 13:28:44 galileo kernel: printer.c: usblp0: USB Bidirectional
printer dev 10 if 0 alt 1 proto 2 vid 0x03F0 pid 0x2304
Mar 24 13:28:47 galileo usb.agent[31163]: missing kernel or user mode
driver printer
Mar 24 13:28:50 galileo devlabel: devlabel service started/restarted
Mar 24 13:30:14 galileo gconfd (root-29615): GConf server is not in
use, shutting down.
Mar 24 13:30:14 galileo gconfd (root-29615): Exiting
Comment 1 Tim Waugh 2004-12-07 09:22:20 EST

*** This bug has been marked as a duplicate of 81164 ***

Note You need to log in before you can comment on or make changes to this bug.