Bug 81164 - USB printer probing isn't very good
USB printer probing isn't very good
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
: 100425 119075 119970 176385 (view as bug list)
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2003-01-06 07:00 EST by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-24 09:11:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-01-06 07:00:19 EST
Description of problem:
Multiple USB printers are handled badly, and sometimes a single USB printer
shows up multiple times.  USB probe needs re-writing using Till's (much simpler)
method.

(Similar issue in kudzu: multiple USB printers aren't handled.)
Comment 1 Tim Waugh 2003-01-21 07:30:04 EST
Just running the USB backend with no args and parsing the output is probably the
easiest way to fix printconf.
Comment 2 Tim Waugh 2003-07-22 05:55:05 EDT
*** Bug 100425 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2004-12-07 09:22:27 EST
*** Bug 119075 has been marked as a duplicate of this bug. ***
Comment 4 Tim Waugh 2004-12-07 09:25:16 EST
*** Bug 119970 has been marked as a duplicate of this bug. ***
Comment 5 Stephen Warren 2005-01-05 01:29:05 EST
Any progress on this?

I have two USB printers, and under FC3, it seems like I have to power them on in
an appropriate order for things to work right (i.e. the order I used when I
first ran system-config-printers I think) This is annoying, and not something I
really want to explain to my wife:-)

Also, despite having a queue setup for my HP Deskjet 932c, every time I turn it
on, something creates a new queue for it, and I have to manually delete it each
time...

Also, if I manually edit /etc/cups/printers.conf to use a DeviceURI of
usb://HP/DeskJet%20930C?serial=xxxxx instead of the auto-generated
usb:/dev/usb/lpN, something will over-write my changes whenever I power on this
printer. This is extremely annoying, since it means that I can't manually fix
the problem - the system automatically re-creates it.
Comment 6 Tim Waugh 2005-01-05 08:07:29 EST
I hope to fix this for FC4.
Comment 7 Tim Waugh 2006-01-26 04:43:28 EST
*** Bug 176385 has been marked as a duplicate of this bug. ***
Comment 8 David Woodhouse 2006-03-07 20:42:50 EST
Stephen: See bug #176385 for a workaround. If you set up symlinks and configure
print queues to use those -- ignoring the automatically created print queues
altogether -- then it shouldn't matter which order the printers turn up in.

The annoyance is that you have to ignore the extra print queues which turn up
when you're choosing printers, but that shouldn't be so hard to explain.
Especially as the automatically generated queues can't be shared (even if you do
share them, it forgets all your settings every time it deletes and recreates
those queues), so the only queues your box should be _exporting_ are the ones
you create yourself.
Comment 9 Tim Waugh 2006-04-24 09:11:30 EDT
In FC6 it uses CUPS for this.
Comment 10 Stephen Warren 2007-11-11 15:46:59 EST
Just as some feedback - I just installed F8 on my laptop and the printer setup
stuff looks much better now.

I haven't actually upgraded my server from FC3 (my laptop still uses that as the
backend via IPP), so I don't know if the specific problems I reported here are
fixed, but overall, things are much simpler on the client side these days.

Thanks for all the good work in this area.

Note You need to log in before you can comment on or make changes to this bug.