Bug 1190942 - cycle: doesn't start with wxPython 3.0
Summary: cycle: doesn't start with wxPython 3.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cycle
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1292809 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-10 03:59 UTC by Scott Talbert
Modified: 2018-04-11 10:46 UTC (History)
6 users (show)

Fixed In Version: cycle-0.3.1-18.fc22 cycle-0.3.1-19.fc23
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-19 11:34:26 UTC
Type: Bug


Attachments (Terms of Use)
src.rpm (83.61 KB, patch)
2015-06-05 20:27 UTC, Sergei LITVINENKO
no flags Details | Diff

Description Scott Talbert 2015-02-10 03:59:23 UTC
wxPython has been updated to version 3.0 in Rawhide.  Unfortunately, cycle does not start due to using a deprecated method (EnableYearChange):

Traceback (most recent call last):
  File "/usr/bin/cycle", line 214, in <module>
    app = MyApp(0)
  File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py", line 8628, in __init__
    self._BootstrapApp()
  File "/usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py", line 8196, in _BootstrapApp
    return _core_.PyApp__BootstrapApp(*args, **kwargs)
  File "/usr/bin/cycle", line 203, in OnInit
    self.frame_init()
  File "/usr/bin/cycle", line 207, in frame_init
    frame = MyFrame(None, -1,"")
  File "/usr/bin/cycle", line 82, in __init__
    self.OnCurrent(self)
  File "/usr/bin/cycle", line 180, in OnCurrent
    self.cal.Set_Year(wx.DateTime_Today().GetYear())
  File "/usr/share/cycle/cal_year.py", line 180, in Set_Year
    self.Draw_Year()
  File "/usr/share/cycle/cal_year.py", line 211, in Draw_Year
    self.month[m].EnableYearChange(True)
AttributeError: 'Month_Cal' object has no attribute 'EnableYearChange'

Debian has already patched their cycle package to work with wxPython 3, so it is likely that incorporating that into the Fedora package would resolve the issues:
https://sources.debian.net/data/main/c/cycle/0.3.1-11/debian/patches/07_wxpython3.0.patch

Comment 1 Jaroslav Reznik 2015-03-03 16:52:08 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 2 Sergei LITVINENKO 2015-06-05 20:27:48 UTC
Created attachment 1035408 [details]
src.rpm

prepared by myself src.rpm with proposed patch and small changes of spec file

For endusers - just rebuild it:

rpmbuild --rebuild cycle-0.3.1-18.fc22SL.src.rpm

Comment 3 Sergei LITVINENKO 2015-11-07 10:53:31 UTC
it do not work in f23

two errors in package:

1. Patch for wxPython 3.0 still necessary, because wxPython 2.7 is missed in f23

2. %_iconsdir variable is unknown. cycle.spec have to be changed
 -- icons_dir="%_iconsdir"
 ++ icons_dir="%_datadir/%name/icons"

Comment 4 Fedora Update System 2015-12-04 14:45:19 UTC
cycle-0.3.1-19.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-497f9d921f

Comment 5 Fedora Update System 2015-12-04 14:46:27 UTC
cycle-0.3.1-18.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5796d8fc07

Comment 6 Fedora Update System 2015-12-04 16:50:30 UTC
cycle-0.3.1-19.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cycle'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-497f9d921f

Comment 7 Fedora Update System 2015-12-04 17:20:09 UTC
cycle-0.3.1-18.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update cycle'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5796d8fc07

Comment 8 Sergei LITVINENKO 2015-12-05 11:44:57 UTC
update looks good...

PS: As minimum, it do not crash on start...

Comment 9 A M 2016-01-01 14:08:35 UTC
*** Bug 1292809 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2016-02-21 02:26:53 UTC
cycle-0.3.1-18.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-02-21 16:32:08 UTC
cycle-0.3.1-19.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Thomas Jarosch 2016-03-08 18:10:14 UTC
Related issue:

https://bugzilla.redhat.com/show_bug.cgi?id=1315836


Note You need to log in before you can comment on or make changes to this bug.