Bug 1191053 - Django18
Summary: Django18
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: Changes Tracking   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact:
Pete Travis
URL:
Whiteboard: ChangeAcceptedF22 SystemWideChange Re...
Keywords:
: 1191075 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-10 11:39 UTC by Jaroslav Reznik
Modified: 2015-04-21 19:11 UTC (History)
3 users (show)

Fixed In Version: python-django-1.8-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-09 08:29:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jaroslav Reznik 2015-02-10 11:39:09 UTC
This is a tracking bug for Change: Django18
For more details, see: https://fedoraproject.org//wiki/Changes/Django18

Update python-django to version 1.8.

Comment 1 Jaroslav Reznik 2015-02-10 12:49:04 UTC
*** Bug 1191075 has been marked as a duplicate of this bug. ***

Comment 2 Jaroslav Reznik 2015-02-20 10:01:44 UTC
This message is a reminder that Fedora 22 Change Checkpoint: Completion deadline (testable) is on 2015-02-24 [1].

At this point, all accepted Changes should be substantially complete, and testable. Additionally, if a change is to be enabled by default, it must be so enabled at Change Completion deadline.

This bug should be set at least to the MODIFIED state to indicate that it achieved completeness. Status will be provided to FESCo right after the deadline. If, for any reasons, your Change is not in required state, let me know and we will try to find solution. Fedora 22 is going to be strictly time based release. For Changes you decide to cancel/move to the next release, please use the NEW status and set needinfo on me and it will be acted upon. 

In case of any questions, don't hesitate to ask Wrangler (jreznik). Thank you.

[1] https://fedoraproject.org/wiki/Releases/22/Schedule

Comment 3 Matthias Runge 2015-02-23 09:23:49 UTC
Django project still has Django-1.8 alpha 1. It was released Jan 17th.

Currently 1 single release blocker bug:
https://code.djangoproject.com/query?status=assigned&status=new&version=master&severity=Release+blocker

Comment 4 Matthias Runge 2015-02-24 15:18:15 UTC
After discussing this on irc, I will push the latest alpha to rawhide on Feb. 25th. 

If possible, I'll do the same for f22 branch.

Comment 5 Matthias Runge 2015-02-25 08:07:51 UTC
If the following is true, I'd wait for the beta instead of pushing an alpha version.
-----------------

Subject: 	Re: status of 1.8 release blockers
Date: 	Tue, 24 Feb 2015 17:08:39 -0800 (PST)
From: 	Tim Graham <timograham@gmail.com>
Reply-To: 	django-developers@googlegroups.com
To: 	django-developers@googlegroups.com



Zero blockers as of this writing. If we survive the next 12 hours with
no new ones, I'll release the beta around then (famous last words).

Comment 6 Matthias Runge 2015-02-25 22:18:21 UTC
Just built python-django-1.8-0.5.b1.fc23 in rawhide.

Comment 7 Fedora Blocker Bugs Application 2015-02-26 14:13:59 UTC
Proposed as a Freeze Exception for 22-alpha by Fedora user mrunge using the blocker tracking app because:

 Django-1.8 beta was released 1 day after alpha freeze.
It's now included in rawhide and should be allowed to be pushed to f22.
It is NOT build for f22

Comment 8 Fedora Update System 2015-02-26 20:00:10 UTC
python-django-1.8-0.5.b1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-django-1.8-0.5.b1.fc22

Comment 9 Fedora Update System 2015-02-27 19:43:20 UTC
Package python-django-1.8-0.5.b1.fc22:
* should fix your issue,
* was pushed to the Fedora 22 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-django-1.8-0.5.b1.fc22'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-2756/python-django-1.8-0.5.b1.fc22
then log in and leave karma (feedback).

Comment 10 Petr Schindler 2015-03-02 20:25:32 UTC
Discussed at today's blocker review meeting [1].

This bug was rejected as Freeze Exception - This package doesn't come included on any release media and can be fixed with an update at a later date. No need for FE status.

http://meetbot.fedoraproject.org/fedora-blocker-review/2015-03-02/

Comment 11 Pete Travis 2015-03-08 06:05:45 UTC
I've written some stuff at https://fedoraproject.org/wiki/Documentation_Development_Web_Beat#Django_1.8 to cover this change. Matthias, feel free to edit or ping me if you see room for change or improvement.

Comment 12 Fedora Update System 2015-03-09 08:29:33 UTC
python-django-1.8-0.5.b1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Matthias Runge 2015-03-09 09:55:03 UTC
(In reply to Pete Travis from comment #11)
> I've written some stuff at
> https://fedoraproject.org/wiki/Documentation_Development_Web_Beat#Django_1.8
> to cover this change. Matthias, feel free to edit or ping me if you see room
> for change or improvement.

Thank you Pete, very much appreciated!

Comment 14 Fedora Update System 2015-04-08 13:27:48 UTC
python-django-1.8-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/python-django-1.8-1.fc22

Comment 15 Fedora Update System 2015-04-21 19:11:06 UTC
python-django-1.8-1.fc22 has been pushed to the Fedora 22 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.