Bug 119112 - Contains $RPM_BUILD_ROOT
Contains $RPM_BUILD_ROOT
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: octave (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
David Lawrence
: EasyFix
: 112746 (view as bug list)
Depends On:
Blocks: FC2Target
  Show dependency treegraph
 
Reported: 2004-03-25 00:50 EST by Enrico Scholz
Modified: 2007-04-18 13:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 08:14:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2004-03-25 00:50:10 EST
Description of problem:

https://www.redhat.com/archives/fedora-devel-list/2004-March/msg00492.html


/usr/share/octave/ls-R  contains the $RPM_BUILD_ROOT

| $ cat /usr/share/octave/ls-R
| /var/tmp/octave-2.1.50-root/usr/share/octave:
| 2.1.50


Version-Release number of selected component (if applicable):

octave-2.1.50-8.1


Bugclass-Cookie: uO55bb
Comment 1 Karsten Hopp 2004-03-31 06:56:11 EST
fixed in octave-2.1.50-9 
Comment 2 Lon Hohberger 2004-03-31 11:25:33 EST
*** Bug 112746 has been marked as a duplicate of this bug. ***
Comment 3 Matthias Saou 2004-09-01 06:52:44 EDT
Reopening this bug because the current Fedora Core Development package
still references $RPM_BUILD_ROOT in its %preun scriplet, which is wrong :

$ rpm -qp --scripts octave-2.1.57-3.i386.rpm
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
/sbin/install-info --info-dir=/usr/share/info/
--section="Programming:" --entry="* Octave:(octave).            
Interactive language for numerical computations."
/usr/share/info/octave.info.gz
preuninstall scriptlet (using /bin/sh):
if [ "$1" = "0" ]; then
   /sbin/install-info --delete --info-dir=/usr/share/info
/usr/share/info/octave.info.gz
fi
 
#
# Remove library links
# XXX Kind of unclean.
#
RM_SAFE=0
if [ -d $RPM_BUILD_ROOT/usr/lib64/octave-2.1.57 ]; then
        pushd $RPM_BUILD_ROOT/usr/lib64 &> /dev/null
        RM_SAFE=1
elif [ -d $RPM_BUILD_ROOT/usr/lib/octave-2.1.57 ]; then
        pushd $RPM_BUILD_ROOT/usr/lib &> /dev/null
        RM_SAFE=1
fi
 
if [ $RM_SAFE -eq 1 ]; then
        rm -f liboctave.so
        rm -f libcruft.so
        rm -f liboctinterp.so
        popd &> /dev/null
fi
postuninstall program: /sbin/ldconfig
Comment 4 Lon Hohberger 2004-09-28 15:03:31 EDT
Fixed in 2.1.57-4 which will be in rawhide soon
Comment 5 Ivana Varekova 2005-01-27 08:14:50 EST
Fixed in FC3.

Note You need to log in before you can comment on or make changes to this bug.