Bug 119146 - fuser can't handle large files
fuser can't handle large files
Status: CLOSED DUPLICATE of bug 98042
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: psmisc (Show other bugs)
2.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-25 10:57 EST by Marizol Martinez
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marizol Martinez 2004-03-25 10:57:08 EST
Description of problem:
The fuser command can't handle files larger than 2 GB. This is the
same bug reported on #66340 but is occurring on RHEL AS 2.1.

Version-Release number of selected component (if applicable):
psmisc-20.1-2

How reproducible:
Always

Steps to Reproduce:
1. Create a large file
   dd if=/dev/null of=foo bs=1 seek=2150000000
2. Use the file
   tail -f foo
3. Call fuser in another process
   /sbin/fuser foo
  
Actual Results:  

The fuser command prints the following warning:

  foo: Value too large for defined data type

Expected Results:  

If the file is in use, fuser should display a PID. 
Otherwise, it should have no output.

Additional Info:

It should be compiled with large file support by adding `getconf
LFS_CFLAGS` to CFLAGS.
Comment 1 Mike A. Harris 2004-03-26 03:32:16 EST

*** This bug has been marked as a duplicate of 98042 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:02:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.