Bug 119196 - The X server warning message when /dev/apm_bios can't be opened is misleading
Summary: The X server warning message when /dev/apm_bios can't be opened is misleading
Status: CLOSED DUPLICATE of bug 119195
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-26 08:16 UTC by Mike A. Harris
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2006-02-21 19:02:10 UTC


Attachments (Terms of Use)

Description Mike A. Harris 2004-03-26 08:16:38 UTC
When the X server starts, it attempts to open /dev/apm_bios normally,
in order to try to access APM services in the kernel.  If the kernel
has APM support built in or loaded, and configured, etc. then APM
support in the X server will generally work.

However, if the user does not have any need for APM support on their
machine and does not have it configured, or does not have a kernel
with APM support loaded, then the X server will not be able to
open /dev/apm_bios.  That is normal behaviour, and not a bug or
a problem of any kind.  In this case, the X server realizes that
it is unable to access the kernel's APM functions, and it just
disables APM support.

Users who do not want/need APM support don't need to know or care
about this.  However, the X server logs a line to the X server
log file when it is unable to open the APM device, which scares
a lot of users, who often think this is some kind of error, and
may be responsible for some random problem they are having with
the X server.

(WW) Open APM failed (/dev/apm_bios) (No such device)

Since the error message given above by the X server is not very
detailed or informative to the average user, it is not surprising
that many users consider this to be the cause of random problems,
when it is just a harmless message.  Most users probably don't even
know what APM is, and are thus even more likely to think this (WW)
warning is the cause of their problems.


Solution:

The above error message should be modified to be more informative
to users in the log file, and be downgraded from (WW) warning to
(II) info level.  Something like:

(II) Operating system APM services via /dev/apm_bios are unavailable,
     so APM power management features in the X server will not be
     used.  If you require APM power management features, please
     ensure your BIOS and operating system kernel are configured to
     provide APM services.  This message is just an informative
     message which can be safely ignored, and is not an error.

Comment 1 Alan Cox 2004-05-03 15:50:12 UTC

*** This bug has been marked as a duplicate of 119195 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:02:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.