Bug 119262 - [firewire] probing for ieee1394 modules hangs kernel
[firewire] probing for ieee1394 modules hangs kernel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
:
: 118194 119916 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-03-27 19:34 EST by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.6-1.435
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 21:26:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes the kudzu lock up (363 bytes, patch)
2004-05-15 07:34 EDT, Alexandre Oliva
no flags Details | Diff

  None (edit)
Description Alexandre Oliva 2004-03-27 19:34:37 EST
If /etc/modprobe.conf does not contain `alias ieee1394-controller
ohci1394', running hwbrowser or kudzu hangs the system.  After the
ohci1394 module is loaded (which rc.system does if this entry exists
in modprobe.conf), then running these programs work.

One can get to this situation by installing the system and then adding
a PCI Firewire controller.   This Leadership firewire controller
claims to be a fw323 controller.

Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253.2.1
Comment 1 Bill Nottingham 2004-03-29 15:52:21 EST
Please try a newer kernel.
Comment 2 Alexandre Oliva 2004-03-30 22:14:47 EST
Same problem with 2.6.4-1.298.  Note that I have to NOT have the
following line in /etc/modprobe.conf for the problem to occur:
alias ieee1394-controller ohci1394

This line is added by the installer, so regular use is fine.  It only
fails if you happen to install the system and then add the PCI card to
the system.  Here's what lspci -v says about the card:

00:0c.0 FireWire (IEEE 1394): Lucent Microelectronics FW323 (rev 61)
(prog-if 10 [OHCI])
        Subsystem: Lucent Microelectronics FW323
        Flags: bus master, medium devsel, latency 32, IRQ 11
        Memory at e0000000 (32-bit, non-prefetchable)
        Capabilities: [44] Power Management version 2
Comment 3 Alexandre Oliva 2004-03-30 22:19:48 EST
Err...  I failed to mention that I'm not using the ieee1394 drivers
from this kernel (they won't even build), but rather revision 1193
from the ieee1394 repository, with every ieee1394 driver built as a
module.
Comment 4 Alexandre Oliva 2004-04-08 16:59:32 EDT
SVN revision 1203 from the linux1394 repository no longer locks the
system up, but kudzu is still blocked because modprobe -r ohci1394
won't complete.  Again, it only does this if a ieee1394 controller is
not listed in /etc/modprobe.conf, so this shouldn't affect anyone but
those who add an ieee1394 controller to a pre-installed system.
Comment 5 Alexandre Oliva 2004-05-15 07:34:06 EDT
Created attachment 100244 [details]
Fixes the kudzu lock up

Unfortunately, this didn't make it to FC2, but there are relatively
easy-to-follow instructions to get working firewire on FC2 at
http://people.redhat.com/aoliva/snapshots/FC2-firewire/
Comment 6 mark 2004-05-15 13:03:26 EDT
bugs 118194, 118202, and 119916 are all related to firewire & kudzu...
someone might want to look at them and see if this fix eliminates
those bugs as well...
Comment 7 Alexandre Oliva 2004-05-16 05:09:21 EDT
*** Bug 118194 has been marked as a duplicate of this bug. ***
Comment 8 Alexandre Oliva 2004-05-16 05:14:20 EDT
*** Bug 119916 has been marked as a duplicate of this bug. ***
Comment 9 Dave Jones 2004-06-14 20:06:44 EDT
should be fixed in the errata kernel ?
Comment 10 Kevin R. Page 2004-06-20 13:42:39 EDT
Running errata kernel 2.6.6-1.435smp with kudzu-1.1.62-1, if the
following line is missing from /etc/modprobe.conf:
  alias iee1394-controller ohci1394

then kudzu still blocks. Adding the line (isn't that kudzu's job? ;)
fixes everything.

(for info: I may have manually removed this line myself after
upgrading to FC2 (when ieee1394 was disabled in kernel), possibly to
get rid of a warning/error about missing ieee1394 - I guess if most
people don't mess, they won't hit this problem!)

Note You need to log in before you can comment on or make changes to this bug.