Bug 119916 - [firewire] kudzu service hangs
[firewire] kudzu service hangs
Status: CLOSED DUPLICATE of bug 119262
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-02 22:58 EST by Clyde E. Kunkel
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clyde E. Kunkel 2004-04-02 22:58:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
Q312461; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
After installing FC2T2, system hung at Detecting New Hardware.  Had 
to hard boot to advoic.  Used prompted boot to bypass Detecting New 
Hardware.  Next I stopped the kudzu service and updated the config. 
After upgrading to kernel 2.6.4-1.303smp tried to start kudzu service 
and got hard freeze--no mouse, no keyboard.  Reboot and update kudzu 
to 1.1.54-1.  Service still won't start, however, no longer hard 
freeze, but never get a failure dialogue, start button stays greyed, 
and have to kill services.  Review bugzilla on kudzu and didn't find 
anything like this, tho did see corrupted alias lines in 
modprobe.conf issue which I had and fixed by deleting the bad line.

Version-Release number of selected component (if applicable):
1.1.54-1 and prior

How reproducible:
Always

Steps to Reproduce:
1.select Services from Server Settings menu
2.highlight service kudzu
3.click start
    

Actual Results:  Nothing.  Start box stayed grayed.  Waited 20 mins, 
nothing.  X out of services won't work, get Force Quit dialogue box, 
select Force Quit.

Expected Results:  kudzu service should start, and then Detect New 
Hardware on boot should work properly.

Additional info:

Same system, RHEL3.0 works fine as did FC2T1.
Comment 1 Bill Nottingham 2004-04-05 15:17:35 EDT
Try removing the firewire modules?
Comment 2 Clyde E. Kunkel 2004-04-05 19:41:03 EDT
I removed the firewire modules and then used interactive boot to 
bypass new hardware detection.

I have resolved the problem, at least for now.  I started kudzu from 
a terminal and discovered that it was finding that my hardware had 
changed and was asking me if I wanted to update.  After replying 
appropriately, I then went back to the gui and starting the service 
by clicking the start button resulted in a message that kudzu had 
run.  I then added kudzu back into the startup routine and booting 
was normal.  The problem seems to be that if you have disabled kudzu 
and then try to start it from the gui and it wants to talk to you, it 
is not doing so and so it waits forever for your response which you 
don't see.  Starting it from a terminal allows you to see its query 
and respond.  I don't know if this is a bug or not.

BTW, now running kernel 305smp with firewire added back in and no 
problems as far as I can see.
Comment 3 Alexandre Oliva 2004-05-16 05:14:17 EDT

*** This bug has been marked as a duplicate of 119262 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:22 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.