Bug 119265 - ppc32 should have /dev/adb and /dev/pmu
ppc32 should have /dev/adb and /dev/pmu
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
rawhide
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 121178 (view as bug list)
Depends On:
Blocks: 120809 126024
  Show dependency treegraph
 
Reported: 2004-03-27 23:45 EST by Nathan Robertson
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 20:18:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add /dev/adb and /dev/pmu to the ppc build of MAKEDEV / dev (330 bytes, text/plain)
2004-03-27 23:47 EST, Nathan Robertson
no flags Details

  None (edit)
Description Nathan Robertson 2004-03-27 23:45:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
PowerMac (ppc) machines should have /dev/adb (the bus that drives ADB
mice / keyboards).

/dev/pmu is the Power Management device for PowerMacs. We should have
this too.

I'll attach a patch to the spec file which will do this.


Version-Release number of selected component (if applicable):
MAKEDEV-3.3.13-1

How reproducible:
Always

Steps to Reproduce:
1. Try to use any program that interfaces /dev/adb or /dev/pmu, such
as pbbuttonsd.

Additional info:
Comment 1 Nathan Robertson 2004-03-27 23:47:12 EST
Created attachment 98907 [details]
add /dev/adb and /dev/pmu to the ppc build of MAKEDEV / dev
Comment 2 Nalin Dahyabhai 2004-04-15 03:52:58 EDT
Should these device nodes be present on ppc64 systems as well?
Comment 3 Nathan Robertson 2004-04-15 13:32:09 EDT
For pSeries, I doubt it. If those users aren't complaining about them
not being there, then I guess they don't need them. The exception may
be the G5, but I'd take that as a separate bug if somebody reports it.
I don't have any ppc64 hardware to test with (I'm testing on G3 and G4).
Comment 4 David Woodhouse 2004-04-18 12:32:42 EDT
*** Bug 121178 has been marked as a duplicate of this bug. ***
Comment 5 David Woodhouse 2004-04-18 12:35:03 EDT
Might as well include the device nodes on ppc64 too, as it does no
harm there, and G5 powerbooks will eventually turn up.
Comment 6 Barry K. Nathan 2004-05-22 18:30:48 EDT
Are there going to be any G5 PowerBooks with *ADB*? /dev/pmu on ppc64
in anticipation of a PowerBook G5 makes sense, but /dev/adb?

IMO it would make the most sense to create /dev/adb and /dev/pmu on
ppc32, and /dev/pmu without /dev/adb on ppc64.
Comment 7 David Woodhouse 2004-05-24 04:21:47 EDT
The G4 powerbooks see the internal keyboard and touchpad as ADB
peripherals. I don't see why the G5 powerbooks should be different.
There's no harm in creating /dev/adb there too.
Comment 8 Barry K. Nathan 2004-05-24 05:18:40 EDT
Ah, I didn't realize that! I thought Apple had completely killed
ADB... Never mind my previous comment, then.
Comment 9 Colin Charles 2004-06-24 09:49:38 EDT
Seems to be fixed with MAKEDEV-3.7-2 (and possibly earlier). 

Note You need to log in before you can comment on or make changes to this bug.