Bug 1192688 - [abrt] gnome-software: gs_local_free(): gnome-software killed by SIGABRT
Summary: [abrt] gnome-software: gs_local_free(): gnome-software killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1187725
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:e063d3b0e97393ad8ef4f3b06f5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-02-14 08:30 UTC by Joachim Frieben
Modified: 2015-04-08 12:18 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-09 21:52:20 UTC


Attachments (Terms of Use)
File: backtrace (28.94 KB, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: cgroup (190 bytes, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: core_backtrace (14.93 KB, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: dso_list (14.19 KB, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: environ (3.39 KB, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: limits (1.29 KB, text/plain)
2015-02-14 08:30 UTC, Joachim Frieben
no flags Details
File: maps (72.26 KB, text/plain)
2015-02-14 08:31 UTC, Joachim Frieben
no flags Details
File: open_fds (1.52 KB, text/plain)
2015-02-14 08:31 UTC, Joachim Frieben
no flags Details
File: proc_pid_status (940 bytes, text/plain)
2015-02-14 08:31 UTC, Joachim Frieben
no flags Details
File: var_log_messages (1.19 KB, text/plain)
2015-02-14 08:31 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2015-02-14 08:30:13 UTC
Version-Release number of selected component:
gnome-software-3.15.4-1.fc22

Additional info:
reporter:       libreport-2.3.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: gs_local_free
executable:     /usr/bin/gnome-software
kernel:         3.19.0-1.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1001

Truncated backtrace:
Thread no. 1 (10 frames)
 #7 gs_local_free at ../../src/gs-cleanup.h:68
 #8 gs_plugin_fedora_tagger_download at gs-plugin-fedora-tagger-ratings.c:360
 #9 gs_plugin_fedora_tagger_load_db at gs-plugin-fedora-tagger-ratings.c:523
 #10 gs_plugin_refine at gs-plugin-fedora-tagger-ratings.c:631
 #11 gs_plugin_loader_run_refine_plugin at gs-plugin-loader.c:190
 #12 gs_plugin_loader_run_refine at gs-plugin-loader.c:252
 #13 gs_plugin_loader_run_results at gs-plugin-loader.c:417
 #14 gs_plugin_loader_get_installed_thread_cb at gs-plugin-loader.c:1189
 #15 g_task_thread_pool_thread at gtask.c:1215
 #17 g_thread_proxy at gthread.c:764

Potential duplicate: bug 1187725

Comment 1 Joachim Frieben 2015-02-14 08:30:24 UTC
Created attachment 991675 [details]
File: backtrace

Comment 2 Joachim Frieben 2015-02-14 08:30:28 UTC
Created attachment 991676 [details]
File: cgroup

Comment 3 Joachim Frieben 2015-02-14 08:30:33 UTC
Created attachment 991677 [details]
File: core_backtrace

Comment 4 Joachim Frieben 2015-02-14 08:30:39 UTC
Created attachment 991678 [details]
File: dso_list

Comment 5 Joachim Frieben 2015-02-14 08:30:44 UTC
Created attachment 991679 [details]
File: environ

Comment 6 Joachim Frieben 2015-02-14 08:30:48 UTC
Created attachment 991680 [details]
File: limits

Comment 7 Joachim Frieben 2015-02-14 08:31:01 UTC
Created attachment 991681 [details]
File: maps

Comment 8 Joachim Frieben 2015-02-14 08:31:06 UTC
Created attachment 991682 [details]
File: open_fds

Comment 9 Joachim Frieben 2015-02-14 08:31:10 UTC
Created attachment 991683 [details]
File: proc_pid_status

Comment 10 Joachim Frieben 2015-02-14 08:31:16 UTC
Created attachment 991684 [details]
File: var_log_messages

Comment 11 Márcio 2015-02-28 22:20:04 UTC
Another user experienced a similar problem:

I'm using it for the first time on gnome wayland session.

reporter:       libreport-2.4.0
backtrace_rating: 4
cmdline:        /usr/bin/gnome-software --gapplication-service
crash_function: gs_local_free
executable:     /usr/bin/gnome-software
kernel:         4.0.0-0.rc1.git0.1.fc22.x86_64
package:        gnome-software-3.15.90-3.fc22
reason:         gnome-software killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Kalev Lember 2015-03-09 21:52:20 UTC

*** This bug has been marked as a duplicate of bug 1187725 ***


Note You need to log in before you can comment on or make changes to this bug.