Bug 119282 - tcl-8.3.5-92 supplied with EL AS and WS 3 does not contain the include files.
Summary: tcl-8.3.5-92 supplied with EL AS and WS 3 does not contain the include files.
Status: CLOSED DUPLICATE of bug 108621
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcltk   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-28 23:52 UTC by Jim Waldram
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim Waldram 2004-03-28 23:52:54 UTC
Description of problem:
tcl-8.3.5-92 supplied with EL AS and WS 3 does not contain the include
files.

Version-Release number of selected component (if applicable):
8.3.5-92

How reproducible:
fully

Steps to Reproduce:
1.attempt to use tcl include files
2.
3.
  
Actual results:


Expected results:


Additional info:
tcl not included in bugzilla components, tcltk chosen as nearest

Comment 1 Jens Petersen 2004-03-29 12:58:47 UTC
[correct the source package for RHEL 3 is tcltk]

There are plans in the works to release the tcltk -devel
packages before too long.

*** This bug has been marked as a duplicate of 108621 ***

Comment 2 Jim Waldram 2004-03-29 18:15:39 UTC
This is not a tcl -devel or tcltk -devel problem.  Previous releases
of tcl include the header files.  See listing of files in RH 9 tcl
release.

Comment 3 Jim Ockers 2004-03-30 22:44:18 UTC
I agree with comment #2 above - the tcl.h has always been distributed 
as part of the base tcl packages in previous RHL products.  tcl.h is 
used by too many other packages to limit to a tcl-devel package.


Comment 4 Jens Petersen 2004-03-31 00:18:09 UTC
Well the current srpm packages the header files in
tcl-devel, and this package was excluded from the initial
RHEL 3  release.  My understanding is that this is going
to be rectified in a RHEL 3 update soon.

The header files are only needed for building tcl apps, not
running them, that is why they was moved to a separate subpackage
(bug 90087).



Comment 5 Red Hat Bugzilla 2006-02-21 19:02:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.