Bug 119301 - kernel oops (dri, i830, i855GM)
Summary: kernel oops (dri, i830, i855GM)
Status: CLOSED DUPLICATE of bug 117713
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-03-29 08:06 UTC by jan p. springer
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:02:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oops #1 (3.72 KB, text/plain)
2004-03-29 15:45 UTC, jan p. springer
no flags Details
oops #2 (4.03 KB, text/plain)
2004-03-29 15:45 UTC, jan p. springer
no flags Details
oops #3 (1.90 KB, text/plain)
2004-03-29 15:46 UTC, jan p. springer
no flags Details
oops #4 (1.96 KB, text/plain)
2004-03-29 15:46 UTC, jan p. springer
no flags Details
oops #5 (1.88 KB, text/plain)
2004-03-29 15:46 UTC, jan p. springer
no flags Details
cat /proc/cpuinfo (422 bytes, text/plain)
2004-03-29 15:47 UTC, jan p. springer
no flags Details
lspci -vv (10.15 KB, text/plain)
2004-03-29 15:47 UTC, jan p. springer
no flags Details
cat /proc/mtrr (467 bytes, text/plain)
2004-03-29 15:47 UTC, jan p. springer
no flags Details
dmesg (16.29 KB, text/plain)
2004-03-29 15:48 UTC, jan p. springer
no flags Details
dmidecode (14.71 KB, text/plain)
2004-03-29 15:48 UTC, jan p. springer
no flags Details

Description jan p. springer 2004-03-29 08:06:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031016

Description of problem:


Version-Release number of selected component (if applicable):
kernel-2.6.3-2.1.253.2.1

How reproducible:
Always

Steps to Reproduce:
1. enable dri uasge in XF86Config
2. init 5
3. glxgears


Actual Results:  x server frozen

Expected Results:  accelerated gfx output

Additional info:

Comment 1 Arjan van de Ven 2004-03-29 08:10:57 UTC
1) what hardware is this ?
2) can you copy relevant parts of the oops ?

Comment 2 jan p. springer 2004-03-29 15:45:27 UTC
Created attachment 98928 [details]
oops #1

Comment 3 jan p. springer 2004-03-29 15:45:47 UTC
Created attachment 98929 [details]
oops #2

Comment 4 jan p. springer 2004-03-29 15:46:04 UTC
Created attachment 98930 [details]
oops #3

Comment 5 jan p. springer 2004-03-29 15:46:22 UTC
Created attachment 98931 [details]
oops #4

Comment 6 jan p. springer 2004-03-29 15:46:38 UTC
Created attachment 98932 [details]
oops #5

Comment 7 jan p. springer 2004-03-29 15:47:01 UTC
Created attachment 98933 [details]
cat /proc/cpuinfo

Comment 8 jan p. springer 2004-03-29 15:47:27 UTC
Created attachment 98934 [details]
lspci -vv

Comment 9 jan p. springer 2004-03-29 15:47:56 UTC
Created attachment 98935 [details]
cat /proc/mtrr

Comment 10 jan p. springer 2004-03-29 15:48:20 UTC
Created attachment 98936 [details]
dmesg

Comment 11 jan p. springer 2004-03-29 15:48:38 UTC
Created attachment 98937 [details]
dmidecode

Comment 12 jan p. springer 2004-03-29 15:57:32 UTC
its a centrino based notebook (alienware area51-m;sentia)
remarks:
1. the intel windows gfx driver reports 64MB memory for the gfx
adapter while agpgart reports 128M; this is (in principle) a dual head
system, so agpgart doesn't get it?
2. i've seen one report on lkml that the i830 should be extended for
i855 (as it has been for i845)
3. i currently have the agp/drm stuff in-kernel but i will build
another kernel where they are modularized (again); if nesssecary i can
(again) provide the oops traces
4. i can successfully shutdown (through acpid tracking pwrbtn usage);
so the system is still stable only the x server hangs


Comment 13 Michael Young 2004-03-29 16:05:09 UTC
triage->duplicate 117713
duplicate of bug 117713

Comment 14 Arjan van de Ven 2004-03-29 16:10:20 UTC
ah this one I fixed last week ;)
see the kernel on http://people.redhat.com/arjanv/2.6/

Comment 15 Bill Nottingham 2004-03-29 21:43:35 UTC

*** This bug has been marked as a duplicate of 117713 ***

Comment 16 jan p. springer 2004-03-30 09:49:29 UTC
still not working
2.6.4-1.298, dmesg:
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected an Intel 855 Chipset.
agpgart: Maximum main memory to use for agp memory: 933M
agpgart: Detected 8060K stolen memory.
agpgart: AGP aperture is 128M @ 0xf0000000
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
[drm] Initialized i830 1.3.2 20021108 on minor 0
mtrr: base(0xf0020000) is not aligned on a size(0x800000) boundary
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
[drm:i830_wait_ring] *ERROR* space: 128384 wanted 131064
[drm:i830_wait_ring] *ERROR* lockup
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
[drm:i830_wait_ring] *ERROR* space: 131056 wanted 131064
[drm:i830_wait_ring] *ERROR* lockup
mtrr: base(0xf0020000) is not aligned on a size(0x800000) boundary
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
[drm:i830_wait_ring] *ERROR* space: 130648 wanted 131064
[drm:i830_wait_ring] *ERROR* lockup
mtrr: base(0xf0020000) is not aligned on a size(0x800000) boundary
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000
[drm:i830_wait_ring] *ERROR* space: 130648 wanted 131064
[drm:i830_wait_ring] *ERROR* lockup
mtrr: base(0xf0020000) is not aligned on a size(0x800000) boundary
mtrr: 0xf0000000,0x8000000 overlaps existing 0xf0000000,0x400000

i checked with the kernel rpm as well as a modularized self-built one

btw. since this bug is now a duplicate where should i add future comments?

Comment 17 Mike A. Harris 2004-03-30 10:15:57 UTC
When bugs are closed as a duplicate of another bug, future comments
should be added to the master bug, so the issue can be tracked in
one location.

Hope this helps.

Comment 18 Red Hat Bugzilla 2006-02-21 19:02:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.