Bug 121846 - (DRI I845) System hangs/crashes w/OpenGL screensaver
(DRI I845) System hangs/crashes w/OpenGL screensaver
Status: CLOSED DUPLICATE of bug 119311
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-04-28 12:49 EDT by O.K.
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description O.K. 2004-04-28 12:49:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
The system, configured to random screensaver, used to 'hang' from 
time to time.
Activating xscreensaver-demo and (accidently) choosing an OpenGL 
screensaver "freeses" the display and hangs the whole machine.
Non OpenGL screensavers work fine (and xscreensaver-demo w/non-OpenGL)
Machine detailes: Compaq Evo, Pentium4@1.8GHz, 256MB RAM
Video card: "82845G/GL [Brookdale-G] Chipset Integrated Graphics 
Device"


Version-Release number of selected component (if applicable):
xscreensaver-4.14-3

How reproducible:
Always

Steps to Reproduce:
1.Run xscreensaver-demo
2.Choose (click on-) an OpenGL screensaver - the machine hangs!
or
1. Edit ~/.xscreensave to run an OpenGL screensaver
2. lock the screen

    

Actual Results:  as expected, the machine hung.

Expected Results:  the xscreensaver/xscreensaver-demo should run :-)

Additional info:
Comment 1 Bill Roman 2004-04-30 16:42:41 EDT
This is happening for me on Fedora Core 2 test 3, up to date as of
right now.

When hung, the system does not respond to Ctrl-Alt-F keys, nor does it
shut down as normal when the ACPI power switch is pressed. The hang
freezes ssh connections, but the system still responds to pings.

The X server logs:

(--) PCI:*(0:2:0) Intel Corp. 82845G/GL [Brookdale-G] Chipset
Integrated Graphics Device rev 1, Mem @ 0xf0000000/27, 0xfc400000/19

Other bugs I suspect are related:

bug 121846: System hangs/crashes w/OpenGL screensaver
bug 121222: Kernel Freeze Runinng Screensavers
bug 119705: crash caused by screensaver on i845G
bug 117713: i830 DRM assert in 2.6.3-2.1.242
bug 107270: Please turn off OpenGL screensavers by default
                                                                     
          
Comment 2 Arjan van de Ven 2004-05-03 06:07:28 EDT
can you try the kernel at http://people.redhat.com/arjanv/2.6
we fixed a critical bug in this code yesterday
Comment 3 Alan Cox 2004-05-03 11:43:59 EDT

*** This bug has been marked as a duplicate of 119311 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:02:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.