Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
I Installed sat6.1 snap2 and checked the gutterball status using curl command and got 404
[root@dhcp201-167 ~]# curl -k https://localhost:8443/gutterball/status
<html><head><title>Apache Tomcat/6.0.24 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 404 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>The requested resource () is not available.</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/6.0.24</h3></body></html>[root@dhcp201-167 ~]#
I've updated the /etc/foreman/settings.yaml file with:
--
:foreman_gutterball:
:url: https://<hostname>/gutterball
--
and restarted foreman service after making above change.
Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20150210.0
Sat6.1.0 beta snap2
ruby193-rubygem-foreman_gutterball-0.0.1.4-1.el6_6sat.noarch
rubygem-hammer_cli_gutterball-0.0.1.1-1.el6_6sat.noarch
gutterball-1.0.10-1.el6.noarch
gutterball-certs-1.0-1.noarch
[root@dhcp201-167 ~]#
How reproducible:
always
Steps to Reproduce:
1. install compose and check gutterball status
2.
3.
Actual results:
404
Expected results:
user should be able to see gutterball up and running
Additional info:
[root@dhcp201-167 ~]#
here are the exceptions in gutterball.log
cat /var/log/gutterball/gutterball.log
2015-02-16 17:09:36,796 [main] INFO org.candlepin.gutterball.servlet.GutterballContextListener - Gutterball initializing context.
2015-02-16 17:09:36,800 [main] INFO org.candlepin.gutterball.servlet.GutterballContextListener - Gutterball reading configuration.
2015-02-16 17:09:37,758 [main] INFO org.candlepin.gutterball.receiver.EventReceiver - Configured SSL properites.
2015-02-16 17:09:38,226 [IoReceiver - localhost/127.0.0.1:5671] WARN org.apache.qpid.transport.network.security.ssl.SSLUtil - Exception received while trying to verify hostname
2015-02-16 17:09:38,252 [main] ERROR org.candlepin.gutterball.servlet.GutterballGuiceResteasyBootstrap - Could not create Guice injector.
com.google.inject.CreationException: Guice creation errors:
1) Error injecting constructor, org.apache.qpid.AMQConnectionFailureException: SSL hostname verification failed. Expected : localhost Found in cert : dhcp201-167.englab.pnq.redhat.com [error code 200: reply success]
at org.candlepin.gutterball.receiver.EventReceiver.<init>(EventReceiver.java:57)
at org.candlepin.gutterball.guice.GutterballModule.configureEventReciever(GutterballModule.java:153)
while locating org.candlepin.gutterball.receiver.EventReceiver
1 error
at com.google.inject.internal.Errors.throwCreationExceptionIfErrorsExist(Errors.java:435) ~[guice-3.0-redhat-1.jar:3.0-redhat-1]
at com.google.inject.internal.InternalInjectorCreator.injectDynamically(InternalInjectorCreator.java:183) ~[guice-3.0-redhat-1.jar:3.0-redhat-1]
at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:109) ~[guice-3.0-redhat-1.jar:3.0-redhat-1]
at com.google.inject.Guice.createInjector(Guice.java:95) ~[guice-3.0-redhat-1.jar:3.0-redhat-1]
at org.candlepin.gutterball.servlet.GutterballContextListener.getInjector(GutterballContextListener.java:95) [GutterballContextListener.class:
I installed snap3 and getting same 404 on accessing the gutterball status with
curl -k https://localhost:8443/gutterball/status.
I'm really not sure what needs to be done on sat6.1 compose to work with gutterball via api:
That error message ("SSL hostname verification failed.") indicates a problem making the SSL/TSL connection to the event bus that Gutterball relies on.
The Katello installer needs to create an /etc/gutterball/gutterball.conf file with the following:
gutterball.amqp.connect = amqp://guest:guest@FQDNHERE/test?brokerlist='tcp://FQDNHERE:5671?ssl='true'&ssl_cert_alias='gutterball''
Or for quick testing, you can simply add that option to /etc/gutterball/gutterball.conf yourself.
Just for historical purposes, this issue was introduced with the Java Qpid client version 0.30 (See https://issues.apache.org/jira/browse/QPID-5960). It is actually good that they fixed that issue, but it uncovered incorrect configuration in Katello.
Verified with sat6.1.1 GA snap11 compose2.
I can see the gutterball status.
~]# curl -k https://localhost:8443/gutterball/status
{
"version" : "1.0.15.0",
"release" : "1",
"request_locale" : "en_US"
}[root@cloud-qe- ~]#
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHSA-2015:1592